Page MenuHome

Proportional Editing (Edit Mode) not working on Operation Panel (Blender 2.80 Beta, Hash: abaf6b106d3a, master, Date: 2019-06-25)
Open, Confirmed, HighPublic

Description

Operating system: Microsoft Windows 10 Pro (Version 10.0.17134 Build 17134)
Graphics card: NVIDIA GeForce GTX 1080 (Driver Version 26.21.14.3086)

Blender 2.80 Beta, Hash: abaf6b106d3a, master, Date: 2019-06-25

Proportional Editing (Edit Mode) not working on Operation Panel:

Under condition of:

  • Either Proportional Editing on or off. With any falloff mode, and active of Connected Only or Projected from View.
  • Either Proportional Editing on or off. With Transformation Orientation set to Normal, Pivot Point set to Individual Origin.
  • Make changing to any selected face, edge, vertex on their location, rotation, scale.

After confirm operation above (Either Proportional Editing on or off):

  • Proportional Editing on earlier, make adjustment to any thing on Operation Panel kind of reset action making earlier. (Transformation Orientation set to Normal, Pivot Point set to Individual Origin)
  • Proportional Editing off earlier, turn on at Operation Panel, the result doesn't seem to be what it should. (Transformation Orientation set to Normal, Pivot Point set to Individual Origin)

For example as shown in the images. With Transformation Orientation set to Normal, Pivot Point set to Individual Origin.
Turn on Proportional Editing, rotating 12 selected pentagonal faces in 230°, result is expected.
When readjust any thing at Operation Panel, the result goes crazy.
The situation same as doing the rotation first, then turn on turn on Proportional Editing at Operation Panel.

Sorry to my bad English, hopefully you guys get what I means. Thanks.

  • Update: When one face, edge, or vertex run the action with condition above, the result has no problem.

The images shown comparison on 2.79 and 2.80(the version write above the post earlier), before and after the action made.

Proportional Edit Blender Sample:

Transformation Blender Sample:

Demo:

Demo (Object Mode - Local, Individual Origin) v2.80 RC:

Event Timeline

B-Lee (toki46) renamed this task from Proportional Editing (Edit Mode) not working on Operation Panel to Proportional Editing (Edit Mode) not working on Operation Panel (Blender 2.80 Beta, Hash: abaf6b106d3a, master, Date: 2019-06-25).
Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.

Could you attach the example file in your pictures so we can easily reproduce?

File attach done, is side I put 2 objects, one is the result of using proportional editing to rotate individual normal and make adjustment at operation panel. The other one is before doing it. Thanks.

Could you attach the example file in your pictures so we can easily reproduce?

Just found out, maybe the problem is not proportional editing,
but the Transformation using Normal Orientation and Individual Origin Pivot Point.
Then readjustment on operational panel active the problem.

Sebastian Parborg (zeddb) raised the priority of this task from Needs Information from User to Confirmed, Medium.
Sebastian Parborg (zeddb) raised the priority of this task from Confirmed, Medium to Confirmed, High.Jul 8 2019, 6:15 PM

Hi Sebastian, I just found a similar problem like this one, only it happen in Object Mode.
When in Object Mode, using Local transformation orientation and Individual Origin pivot point to rotate or move objects they'll act the same as this post, exclude the middle (0, 0, 0) cube.
I am using v2.80 RC just release to do the test.
I don't know whether it is under the same code of this one or not, but I'll attach a demo video above here for now.