Page MenuHome

Limit Scale Constraint Issue
Closed, ArchivedPublic

Description

System Information
Operating system: Darwin-18.6.0-x86_64-i386-64bit 64 Bits
Graphics card: NVIDIA GeForce GTX 780M OpenGL Engine NVIDIA Corporation 4.1 NVIDIA-12.0.23 355.11.10.50.10.103

Blender Version
Broken: version: 2.80 (sub 74), branch: master, commit date: 2019-06-27 21:28, hash: rB5dd8c3f0cb83
Worked: (optional)

Short description of error
Limit Scale Constraint behaves unexpected

Exact steps for others to reproduce the error
I made a rig where an empty controls the shape of a bezier curve by its scale (simple driver)
The empty has a Limit Scale Constraint from 0.5 to 1.0 (see video on the right)
I still can scale the empty from -1.0 to 1.0

Details

Type
Bug

Event Timeline

That's weird. I tried to replicate this by adding an empty to the default file and adding a limit scale constraint as shown in your video. But in my case the empty could not be scaled beyond the 0.5 - 1.0 value limitation imposed by the constraint.

I'm on Win 10/64 laptop.

I'm not sure if maybe there's some other issue going on with your driver, or some other problem. I recommend that you upload a blend file with the simplest setup that demonstrates the problem for other users and the developers to examine.

This is a known limitation of the constraint: https://docs.blender.org/manual/en/latest/rigging/constraints/transform/limit_scale.html

@Brecht Van Lommel (brecht) shouldn't the user be warned about this in some way, like maybe having the constraint name getting red when the object's scale gets negative?

Ok, it is a known limitation - but why there is a Limit Scale Constraint when you can't limit the scale properly? It causes me a lot of trouble on a complex rig I am working on.

Example file:

  • pick up the empty
  • scale it in both direction
  • the left object is flipping
Brecht Van Lommel (brecht) closed this task as Archived.Jul 2 2019, 4:29 PM
Brecht Van Lommel (brecht) claimed this task.

If it's a documented limitation it's not a bug to be handled in the tracker, no matter how important it may be to some users.