Page MenuHome

Undo don't restor proper geometry in sculpt mode
Closed, ResolvedPublic

Description

System Information
Operating system: UBUNTU 18.04.02 Linux-4.18.0-25-generic-x86_64-with-debian-buster-sid 64 Bits
Graphics card: GeForce GTX 670MX/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 390.116

Blender Version

Broken: version: 2.80 (sub 74), branch: master, commit date: 2019-06-30 19:51, hash: rBbbb3500c9716

Also broke in the last build of 2.79

Short description of error

When you sculpt something with a very hard edge, like a Blob with a strong fallof, when undo there is broken geometry in all the contour were the blob was. It can be seen in the view-port and when you do again a Blob there is broken geometry in that places.
I can see the error also in wire-frame also. The only way to fix the issue is to go with Shift and pas on the surface, that restore the surface and the shading error in the view port, some brushes also fix the issue when you sculpt near this areas. Also cavity is able to see it in the viewport, that is why I think is a problem with the mesh data, and not the shading.

In 2.79 you have to enable smooth shading to see it, you can't see it with shading flat, but the error occurred when sculpting.

Exact steps for others to reproduce the error
Add a cube then a subdivision modifier with 6 subdivisión apply, go to sculpt mode, make a blob with the stroke in drag dot and an abrupt fallof.

Undo

Make a blob again in the same spot

Also present in 2.79:

Event Timeline

Germano Cavalcante (mano-wii) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Jul 1 2019, 11:21 PM

I can't replicate. Is there any missing step?

No, that is all it is needed, But I think you need to drag the bloob, maybe?

I dragged it and still no difference.
Are you sure you can reproduce this bug in the latest Blender builds?

I just download the last one.

@Germano Cavalcante (mano-wii) The problem exists you need to have smooth shading to see it easily. I can reproduce it.

Same issue in blender 2.79.7 confirmed too.

it is a geometry problem. Here you can see the wireframe.

Also something strage happen when you sculpt with the overlay face orientation enable:

Germano Cavalcante (mano-wii) raised the priority of this task from Needs Information from User to Normal.

Kinda crazy but "cool".... looks like it's weirdly pussing out the 'blob' that suffer a "compression", playing with dots...

The mesh problem is fix, but the visual distortion is still present, Not a big problem though.