Page MenuHome

TexturePaint: Force Workbench Color mode to Texture
Closed, ResolvedPublic

Details

Event Timeline

Jeroen Bakker (jbakker) changed Type from Bug to To Do.
Jeroen Bakker (jbakker) claimed this task.
Jeroen Bakker (jbakker) triaged this task as Confirmed, High priority.

Putting here what I put in chat and tagging @Brecht Van Lommel (brecht) for opinion: How about forcing Weight Paint mode into Flat->Single Color->White shading? It makes no sense to mix color information with the non-color information that is weights, and it's frustrating to switch into and out of weight paint mode right now, see: https://developer.blender.org/T61486#702654

I agree that would be better behavior for weight and vertex paint mode, it makes little sense to mix those with other colors.

We could make changes to other modes as well, but these have less priority than this one. We should rethink about the separations of overlays and render engines, as this task is already breaking the intended design. But I would like to postpone these tasks for after 2.80

Jeroen Bakker (jbakker) closed this task as Resolved.Jul 5 2019, 4:43 PM