Page MenuHome

Crease Function in Multires modifier
Closed, DuplicatePublic

Description

System Information
Operating system: MacOS (current Mojave 10.14.5)
Graphics card: Radeon Pro 570 4GB

Blender Version
Broken: 2.80 Beta
Worked: (optional)

Short description of error
Multires Modifier shows strange functionality with creases. It seems to invert the crease profile.

Sudivision Surface Creases are excellent.

Exact steps for others to reproduce the error
-Default cube, in edit mode crease edges to 0.50.
-Object mode add Multires modifier.
-Subdivide a few times inside the modifier.

Thank You,

James

Event Timeline

Sebastian Parborg (zeddb) lowered the priority of this task from 90 to 30.Jul 10 2019, 10:41 AM

I can not reproduce this, using a cube with a subdiv modifier gives the same result.

Does this still happen with the latest blender beta?

Hello Sebastian,

Thanks for getting back to me on this. I've reproduced the error on a Windows machine and attached the file.

*if the Mean Crease is set to 1.00, everything functions as normal. If it is set to anything below (0.3, 0.5, etc.) the error occurs.

Once again if you use a Subdivision Surface modifier everything is perfect. However, if you use Multiresolution modifier instead, the creased edges produce a strange error.

Thanks Again,

James Light

Sebastian Parborg (zeddb) raised the priority of this task from 30 to 50.

This is caused by a transitional state of code, where Subdivide uses old subdivision algorithm, but sculpting and drawing are using new one: causes mismatch how displacement is being updated and propagated.