Page MenuHome

Export selected in X3D fails with selected parts
Closed, ArchivedPublic

Description

System Information
Operating system: Darwin-18.6.0-x86_64-i386-64bit 64 Bits
Graphics card: AMD Radeon Pro Vega 64 OpenGL Engine ATI Technologies Inc. 4.1 ATI-2.9.26

Blender Version
Broken: version: 2.80 (sub 74), branch: master, commit date: 2019-07-04 22:24, hash: rBfdcfc263e973
Worked: (optional)

Short description of error
When Exporting an X3D model and choosing the only selected option, the export bombs with an error message saying no object has attribute "select"

Exact steps for others to reproduce the error
Add a model and select it
Select file->export->X3D
click "Selection Only"
Then export

Details

Type
Bug

Event Timeline

Brendon Murphy (meta-androcto) triaged this task as Needs Information from User priority.

hi, just tested this in rc2, unable to reproduce this error. Tested on windows. @Nigel Johnson (nigeljohnson73) can you test again with 2.8 rc2 please.

Tested on Win10 and 2.80 RC2, now error says "name" from "mesh" is read only.

I can't reproduce this on current master (785301e5acfbf55208655aba80cde5b2d7b2ee44) by exporting Suzanne to X3D.
@Nigel Johnson (nigeljohnson73) please update the task with a minimal example blend file that shows this problem.

Bastien Montagne (mont29) closed this task as Archived.
Bastien Montagne (mont29) claimed this task.

More than a week without reply or activity. Due to the policy of the tracker archiving for until required info/data are provided.