Page MenuHome

Blender viewport freezing with any and all view ports
Closed, ArchivedPublic

Description

System Information
Operating system: Linux-5.0.0-20-lowlatency-x86_64-with-debian-buster-sid 64 Bits
Graphics card: GeForce GTX 1070/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 430.26

Blender Version
Broken: version: 2.80 (sub 74), branch: master, commit date: 2019-07-06 11:50, hash: rB741f80864e79
Worked: (optional)

Short description of error

So any time I am work in blender 2.8 I will get random freezes in the viewport, it could be simple modeling in workbench, sculpting in workbench, or just navigating a scene in look dev or rendered out in eevee.
The freezes last from 15 - 30 seconds some times even up to a minute.

Exact steps for others to reproduce the error
there is not an exact way of having it freeze, but it definitely happens sculpting in workbench a lot at random. and happens when I am in lookdev just checking out textures on the Van file I attached but some times with will even just freeze in workbench during normal modeling.

it does happen pretty consistently as well in fully rendered view with eevee from time to time. so I dont know if it is my graphics card that blender does not like.

I have attached two files one with a van design I am making and one with a character bust sculpt I was doing for fun to test out the sculpting stability.

Details

Type
Bug

Event Timeline

Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.

I can't reproduce this. Is this still an issue with the latest build?

Yes Sebastian, I was using the latest build yesterday and it was freezing consistently. And ever other freeze would completely crash the file. I was just doing some simple modeling and lighting nothing to crazy.

Do you have any issues with other 3D programs? I would think more people would have reported this if it was a wide spread problem.

The only other program I have issues with is with my video editor. But that is in alpha.

Could it be my CPU causing it. I was monitoring the CPU and didn't see any weird spikes everything seemed fine. Could my psu be the issue, that it us not strong enough for the pull of the gpu in blender?

Yes, Its not just for you . It happens with me too so frequently. T66577 has a solution. I did not try it yet, but it might work for you.

Mustafa, thank goodness its not only me, you said T66577 has a solution who is that? Sorry I am new to the blender community and reporting bugs, sorry for my lack of understanding of how things work around here.

{F7584106}here is an example of me just sculpting and it freezes then and just a simple adjustment to move an object it freezes then as well.

Any specific reason you are using the 5.0.0 kernel?
Might probably not be it at all, but there has been a lot of small updates for the 5.0.x release. So it might be worth a shot to see if newer kernels help.

Other than that, I could see if you run out of ram or something so it is swapping and thus freezes blender.
(And also make sure to retest with the latest blender beta)

Could be the kernel I just recently switched to Linux. I am running ubuntu studio 19.04, how would I go about checking or updating my kernel?

And as far as ram goes I have 32 gigs and like I said I have been monitoring both ram as well as CPU as I work in blender and my ram doesn't go past 4 gigs even while I'm in eevee rendered out.

You can try simply by checking for updates. If uname -a in the terminal still returns 5.0.0 after reboot, then you haven't updated the kernel.

Other than that, I don't know how you should go about updating it on ubuntu studio.

Testing the newest build from today and its still stalling from time to time.

I think i have a similar issue on windows, there are regular freezes while in lookdev or eevee and especially annoying with a lot of textures. The gpu memory is going down and up again while the freeze is happening. I'm on rc1

Hey Daniel, I just switched back over to windows to see if it was blender, I honestly after deep diving don't think its blender It may be my motherboard, I will be testing blender RC1 out more today to see if it is blender at all but I think I found the culprit on my end being my MOBO.

Some other things to check/ensure:

  • Try to start Blender in factory settings (--factory-startup commandline option) (this will ensure whether this is a userpref or addon issue or not).
  • You are using a low-latency kernel, I doubt that could be the issue, but it might be worth trying a regular kernel too?

Also just to be sure, you are indeed using a 64bit build of blender, right? ;)

Also, many other similar reports (like T65939: Eevee shader compilation stalls, freezes OS (Windows), forces to restart computer) suggest that this is often due to heavy texture (4k and above)…

Sybren A. Stüvel (sybren) closed this task as Archived.
Sybren A. Stüvel (sybren) claimed this task.

Since last asking for information it has been 7 or more days, due to the policy of our bug tracker we will have to archive the report until the requested information is given.