Page MenuHome

Collada: Preview on Mac shows issues with transparency
Closed, ArchivedPublic

Description

July 8, 2019 California USA

System Information
Operating system: Darwin-18.6.0-x86_64-i386-64bit 64 Bits
Graphics card: AMD Radeon Pro 575 OpenGL Engine ATI Technologies Inc. 4.1 ATI-2.9.26

Blender Version
Broken: version: 2.80 (sub 74), branch: master, commit date: 2019-07-04 22:24, hash: rBfdcfc263e973
Worked: (optional)

Short description of error
Blender 2.79b for Mac only is no error,
Blender 2.80 for Mac only is most of error.
Do not use Windows @Gaia Clary (gaiaclary) don't use yourself computer on Windows, please transfer to focus Macintosh team and more than deeply inspect for Blender 2.80 Collada (.dae) They will need create new document of Blender 2.80 (July 4, 2019) last download for Mac only.

Exact steps for others to reproduce the error
Read me on .pdf they will need use Macintosh to do.

  1. Open Blender 2.80 (Last download July 4, 2019)
  2. Delete this cube.
  3. Create new cube.
  4. Create Materials [+] 6 list
  5. Change color to image texture on 1, 3, 5 list of materials.
  6. Whatever you can put texture on 1, 3, 5 on .PNG
  7. export Collada (.dae) then popmenu to SL/OSGrid

THEN
You can see preview on Finder can be disappear also upload within FirestormOS-64.app upload too.

Details

Type
Bug

Event Timeline

I have loaded the demo blendfile and exported it on Windows-10 with selection only enabled.

I see a difference in line 256 when comparing to the dae file included in this report.
Also the Collada file seems to be fully OK when i export it. While kent's export seems
to use a somewhat different UV unwrap. I have no idea from where that might come:

<!-- Kent's results -->
<float_array id="Cube-mesh-map-array" count="72">0.625 0 0.375 0.25 0.375 0 0.625 0.25 0.375 0.5 0.375 0.25 0.625 0.5 0.375 0.75 0.375 0.5 0.625 0.75 0.375 1 0.375 0.75 0.375 0.5 0.125 0.75 0.125 0.5 0.875 0.5 0.625 0.75 0.625 0.5 0.625 0 0.625 0.25 0.375 0.25 0.625 0.25 0.625 0.5 0.375 0.5 0.625 0.5 0.625 0.75 0.375 0.75 0.625 0.75 0.625 1 0.375 1 0.375 0.5 0.375 0.75 0.125 0.75 0.875 0.5 0.875 0.75 0.625 0.75</float_array>

<!-- my results -->
<float_array id="Cube_001-mesh-map-0-array" count="72">1 0 0 1 0 0 1 0 0 1 0 0 1 0 0 1 0 0 1 0 0 1 0 0 1 0 0 1 0 0 1 0 2.38419e-7 1 2.38419e-7 0 1 0 1 1 0 1 1 0 1 1 0 1 1 0 1 1 0 1 1 0 1 1 0 1 1 0 1 1 0 1 1 0 1 1 2.38419e-7 1</float_array>

I asked another developer to export this blendfile on OSX 10.12.6 . But he found the exact same results as me. So from my point of view all is good, the exported collada file works.

@Kent Davis (mac4kent):

You know that the image textures are NOT included in the collada file ?

Just in case: You have to make sure that the texture files and the collada file are in the same directory before you import the Collada to another tool or game engine.

If you still are convinced that this is a bug in Blender on MAC then please do this:

  1. with Blender 2.79 create a simple Mesh plane (1 face)
  2. add a Material with an image texture
  3. Export the plane to collada
  1. with Blender 2.80 create a simple Mesh plane (1 face)
  2. add a Material with an image texture
  3. Export the plane to collada
  • Then verify that the collada file from blender 2.79 works for you
  • And verify that the collada file from blender 2.80 is broken for you.

Then finally attach both collada files to this report so that we can see the difference.

July 9, 2019
@Gaia Clary (gaiaclary)
Previous message: I already put same folder together texture, .blender, and .dae in 1 folder together.
...........................................................................................
MacOS 10.12 is old version. Try use MacOS 10.14.5 this time.
Let me take a moments about 1-14 days to work on Blender 2.79b and Blender 2.80 in separate folder.

I will put 1 materials in object color this EEVEE.
I will put 1 materials in object image texture this EEVEE.
...........................................................................................
Come soon
Folder: (Blender 2_79b _1Face_ July_xx_2019)
Folder: (Blender 2_80 _1Face_ July_xx_2019)
See picture:


...........................................................................................
Later not right now (after fix Collada):
Folder: (Blender 2_79b _8Faces_ July_xx_2019)
Folder: (Blender 2_80 _8Faces_ July_xx_2019)
...........................................................................................
I will work on Affinity Designer export .png within 2048px X 2048px.
...........................................................................................
Everything correct my message explain?
Let me know.

Jean First (robbott) closed this task as Invalid.

If I understand the ticket correctly the problem is the Preview and Quicklook function in the OSX Finder are not showing the exported object. After testing a few options I was able to make the object visible: Set the transparency value to 0 or remove the following lines in the dea file:

<transparency>
  <float sid="alpha">1</float>
</transparency>

According to the collada specifications chapter 7-6 ( page 223 and 224 in https://www.khronos.org/files/collada_spec_1_4.pdf ) the default value for the transparency property is 1.0. It seems the OSX Finder uses the value 0 as opaque and 1 as transparent. I think the problem should be reported to apple.

Please reopen the ticket if you think the problem can be solved in blender.

@Jean First (robbott)
Why you put invalid. We did not finish slowly process you should not put invalid. Sigh. I am still stubborn to send again over again.
You must know first place about Macintosh on MacOS 10.14.5 and fix it on collada (.dae) I keep send again until fix it correct.
I make me upset!
.............................
@Gaia Clary (gaiaclary)

I have to create same title part 2
this link here.
@Jean First (robbott) LISTEN ME LISTEN ME Do not make invalid no more. Let Gaia and me work together to send share on Macintosh we still not finish. some more inspect deeply until fix it correct on SL Agni, Aditi, and OSGrid upload everything correct.
Blender 2.79b Collada (.dae) not have anything bug.
@Gaia Clary (gaiaclary) Good you give me more time to explain and inspect. I have to go new create ticket part 2.
https://developer.blender.org/T66643

Let's talk about the issue, not emotions.

Why you put invalid.

According to the collada specification blender is correct and OSX Finder seems wrong.

I have to create same title part 2

Do not create another ticket. Simply reopen this ticket with "Add Action...>Change Status".

Blender 2.79b Collada (.dae) not have anything bug.

Blender 2.79b did not specify the transparency value.

Before investigation any further, please confirm changing the transparency value to 0 in the exported dae file won't fix the problem.

Are you use Macintosh yourself ?

Are you use Macintosh yourself ?

Yes.

Please confirm changing the transparency value to 0 in the exported dae file won't fix the problem.

Can you show me your screenshot about transparency value to 0?
Did you unzip and check you can see?

  1. open "Cube texture July 8 2019.dae" from zip file in this ticket in a texteditor (vi, emacs, textmate, visual code studio, sublime, ...)
  2. go to line 41
  3. change: <float sid="alpha">1</float> to: <float sid="alpha">0</float>
  4. save the file
  5. check the finder if the preview of the file is correct
  1. open "Cube texture July 8 2019.dae" from zip file in this ticket in a texteditor (vi, emacs, textmate, visual code studio, sublime, ...)

No no that is not. Gaia ask me then I put color
................................................................................................
I talk about color see 2 picture on below I give zip last one.
https://developer.blender.org/T66643 you may need check this zip
................................................................................................


I open Blender 2.80 last download July 4, 2019 Open document from below. Export Collada cause no appear preview.
I open Blender 2.80 last download July 9, 2019 I create cube. Export Collada yes I can see cube appear preview.

Did you try open both Blender 2.80 app last download July 4, 2019 and July 9, 2019 you can notice different.

Hi, @Kent Davis (mac4kent) :

What @Jean First (robbott) suggested above is truly what you should do next. Then we can at least be sure that is the issue in your case.

@Jean First (robbott): I think this is remarkable: https://community.khronos.org/t/transparent-and-transparency-revisited/5962

Sigh can you show me screenshot and I will look up.

Making screen shots of text files does not make much sense :(

Please follow the description of @Jean First (robbott) from Wed, Jul 10, 11:45 AM (see above).

I told you. I don't understand text only. That what Ele and Etheria know me already.
Please show me what look like and I will get it to process.

Not sure it helps, but change the value in that line from 1 to 0.

@Jean First (robbott) :
I see your screenshot.
How did you do that script there on .dae?

Gaia Clary (gaiaclary) triaged this task as Needs Information from User priority.Jul 10 2019, 4:55 PM

Download https://github.com/VSCodium/vscodium/releases/download/1.36.1/VSCodium.1.36.1.dmg , install it, open the dae file in VSCodium, change the value and save the dae file.

@Jean First (robbott)
Thank you for give me link and I got DMG open VSCodium.app:
iMac Mojave dark mode already set.


There is big different code on .dae July 4, 2019 Blender 2.80 last download.
Object preview doesn't appear. Just only color cube.

There is big different code on .dae July 9, 2019 Blender 2.80 last download.
Object preview yes appear. Just only color cube.

Zip this one: Blender 3D > Blender 2_80 _1Faces_color July_xx_2019 > 2 different .dae you can see

open the file "Cube color materials 2_80 July 4 2019 last download.dae" in VSCodium, go to line 96, change the value from <float sid="alpha">1</float> to <float sid="alpha">0</float>, save the file. Does the priview in OSX Finder look as you expected ?

And please only upload the relevant file - not all the files.

I just change from 1 to 0
Look funny preview green and white because of July 4, 2019

Let me and you inspect some more take a few days until find out solve problem without tiny bug.

I tested the following cube in blender

and after changing all "transparency" values from "1" to "0" I get the following preview:

@Kent Davis (mac4kent) for me the initial bug "Collada (.dae) miss preview July 8, 2019" is solved and the problem is not in blender but the preview / quicklook in OSX Finder. Do you agree ?

Blender 2.79b Collada .dae is no bug I know. We still not finish and work some more deeply inspect. I totally believe there does Blender not Mac.
Still work some more take few days.
Also Texture (image picture)

I total believe Blender 2.80 lot bug. This is NOT Mac bug!
Blender 2.79b save on Cycles .blend then export all of .dae you can see.
You have to inspect some more deeply to fix it correct.
I am same as Steve Jobs very deeply inspect there have never bug version 1.0 to 7.xx until they fired Steve Job cause 8.0 mess up until Steve Jobs back make 10.0.0 no more bug. Very strictly no more tiny bug.
We keep inspect some more process until everything perfect no bug.
I KNEW IT Blender 2.80 bug!

  1. Open Blender 2.79b and change Cycles then Click (Use Nodes)

  1. change color anything you want on (Color) on materials.
  2. Export collada then change Materials on below Left from Texture popmenu.
  3. Save .blend

THEN
Open Blender 2.80 then open from .blend (2.79b) you can see. I knew it.

so in the zip file you attached you have 5 files:
1 Cube aqua 2_79b.dae
2 Cube aqua 2_80 2019-07-04 Hash fdcfc263e973.dae
3 Cube aqua 2.80 2019-07-8 Hash a42cae160082.dae
4 Cube aqua 2.80 2019-07-9 Hash 3b4054cb586f.dae
5 Cube aqua 2.80 2019-07-10 Hash bb7b741d2f1c.dae

which one shows up in OSX preview:

  1. Yes
  2. No
  3. No
  4. Yes
  5. No

For simplicity lets focus on the two files "3" and "4".

Let's diff them with diff 3\ Cube\ aqua\ 2.80\ 2019-07-8\ Hash\ a42cae160082.dae 4\ Cube\ aqua\ 2.80\ 2019-07-9\ Hash\ 3b4054cb586f.dae

6c6
<       <authoring_tool>Blender 2.80.74 commit date:2019-07-08, commit time:22:16, hash:a42cae160082</authoring_tool>
---
>       <authoring_tool>Blender 2.80.74 commit date:2019-07-09, commit time:22:45, hash:3b4054cb586f</authoring_tool>
8,9c8,9
<     <created>2019-07-10T20:05:23</created>
<     <modified>2019-07-10T20:05:23</modified>
---
>     <created>2019-07-10T20:07:04</created>
>     <modified>2019-07-10T20:07:04</modified>

Ok - there is no major difference in the files, only the expected defferences.

Let's then check the transparency value:

  1. 1
  2. 1

Let's change that value to 0 and check OSX preview:

  1. Yes
  2. No

WHAT ? Now file 3 shows up, but 4 is invisible.

Ok so let's put the transparency value in 3 to 0 and in 4 to 1 and check the preview:

  1. Yes
  2. Yes

Let's diff them again to be sure we did not miss anything diff 3\ Cube\ aqua\ 2.80\ 2019-07-8\ Hash\ a42cae160082.dae 4\ Cube\ aqua\ 2.80\ 2019-07-9\ Hash\ 3b4054cb586f.dae

6c6
<       <authoring_tool>Blender 2.80.74 commit date:2019-07-08, commit time:22:16, hash:a42cae160082</authoring_tool>
---
>       <authoring_tool>Blender 2.80.74 commit date:2019-07-09, commit time:22:45, hash:3b4054cb586f</authoring_tool>
8,9c8,9
<     <created>2019-07-10T20:05:23</created>
<     <modified>2019-07-10T20:05:23</modified>
---
>     <created>2019-07-10T20:07:04</created>
>     <modified>2019-07-10T20:07:04</modified>
28c28
<               <float sid="alpha">0</float>
---
>               <float sid="alpha">1</float>

the diff is as expected.

For me this is the end of investigating this bug. I still think OSX preview / quicklook is wrong - not sure why and how but there is nothing blender can do to fix the situation.

I let the bug tracker gods manage the status of this bug report.

In first place i believe you if you say we have a bug. But as long as i can not understand fully what you try to explain, its really hard to get this fixed. We are seriously trying to help you. So here is how we can get further:

This is what you (YOU!) need to figure out as i can not do this:

  • Please indicate what the bug is in the collada file. (Which lines in the file are wrong)
  • Why do you think it is wrong (explain how we deviate from the Collada specifications)
  • What you think should be the correct output.

If you or anybody else who understands this issue can provide this sort of detailed information then i can happily go ahead and inspect and fix. Otherwise i can not be of any more help.

Additional note for your info:

  • In Blender 2.79 we only export face textures and material image textures of the Blender Render. The export of Cycles Materials was never supported in 2.79 and exporting to collada while working in Cycles is not even tested in 2.79
  • In Blender 2.80 we export node based materials and that works in eevee and cycles.

Yaaaa ay. @Jean First (robbott) correct
I inspect everything but my bad english to explain text only.
I am full deaf and low vision myself.

@Gaia Clary (gaiaclary) Oh really? I thought support Cycles but you said never support cycles of Blender 2.79b I surprise.

@Jean First (robbott)
I get download daily build on Blender 2.80 beta and I will post some more list collada (.dae) next week (July between from 21-27)
My document save on Blender 2.79b original never to change but 2.80 beta did change (.dae) I am still take test.

Hi, @Kent Davis (mac4kent)

It makes no sense to send more and more collada files to "proof" that there is a bug. It looks to me like we have taken great care to understand your issue, explain what is going on and figure out what we need to do. And so far it all ended in this:

=== This is not a blender issue ===

However i am still willing to work on this issue if you can provide this:

1.) What exactly is wrong with the Blender Collada exporter and show us which lines in the Collada file are wrong!
2.) Explain why the lines in the Collada file are wrong (how does the export break the Collada specifications)
3.) Tell us how exactly how we must fix this (and show us where we do not follow the Collada specifications.

If you can convince us that the problem is on the blender side then we will fix whatever needs to be fixed.

Gaia Clary (gaiaclary) renamed this task from Collada (.dae) miss preview July 8, 2019 to Collada: Preview on Mac shows issues with transparency.Jul 17 2019, 1:58 PM

Hi @Gaia Clary (gaiaclary)

  1. I don't know how to use data.
  2. I don't understand "data"
  3. What is Indicate

I edited my previous post in the hope it is more understandable now

@Gaia Clary (gaiaclary)
Oh ok I got it I understand.

  1. I don't know how to work on script code line that what @Jean First (robbott) show me.
  2. for only text I have problem explain exactly. Sigh.

. . .
Any one use Macintosh We can share team and explain everything also screen sharing through iMessage. I have iMessage.

Demeter Dzadik (Mets) closed this task as Archived.

This is a long thread, but from what I could tell, no one disagrees with Jean and Gaia in that this is not a Blender bug, so if that's agreed upon then let's close the ticket to keep the tracker clean. Feel free to continue discussing though.

Why you do close the ticket???? I am tell again, again, again. They need to fix please. more than deeply inspect everything I do accept use Macintosh. I do not accept use Windows.
@Demeter Dzadik (Mets)
I keep stubborn to tell you exactly bug.

We found a workaround for this issue, see D5305

Ah, that's great!

@Kent Davis (mac4kent) I closed cause it was said that it's not a blender issue. This is a Blender bug tracker.

Thankfully Gaia apparently found a way to make it work with your application without (hopefully) breaking compatibility with other applications. That said, you should probably go and report this issue to whoever maintains that application, since, correct me if I'm wrong, my understanding based on the thread is that the problem is on their side, and that underlying problem is still not fixed. (hence "workaround")

July 28, 2019
@Demeter Dzadik (Mets) You should not decide close ticket without ask me to Kent. We still not finish. Please do change from Close to Open.
You @Demeter Dzadik (Mets) need to know about Macintosh to inspect more than deeply everything.
Thank @Gaia Clary (gaiaclary) for show link. Now time to deeply inspect some more everything.
@Jean First (robbott) Would you like more than deeply inspect everything on FirestormOS-64.app and Firestorm-64.app about texture fail see my some pictures below.

On Macintosh Finder preview all pass it work on texture, color. Not worry about July 20 ignore it. July 22 until now pass
Now time to inspect everything on FirestormOS-64.app and Firestorm-64.app more deeply.
I am going send you zip file.


. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
FirestormOS-64.app Firestorm version 6.0.2.56680 (6.0.2.56680)
Build menu > Upload > Mesh Model . . .


. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
Firestorm-64.app Firestorm version 6.2.4.57588 (6.2.4.57588)
Build menu > Upload > Mesh Model . . .
I just paid L$22

I am wait for your answer.

Hi, Kent;

We do not fix bugs in firestorm. if you think there is a bug in blender, then please indicate what blender makes wrong.

I see you try to explain your problem by attaching images but give no explanation of your finds. This may work well for you. It does not work for me at all. I only see images related to importing collada files to a target system by using different versions of the firestorm viewer. This is not related to Blender.

Also, if you can not express the problem in text, then please find someone who can help you to write a bug report. Please open a new report with a proper description of your issue when you are ready. Then we will do our very best to fix any issues on the Blender side if there are issues at all.

cheers,
Gaia

@Gaia Clary (gaiaclary) Yes. I will do make new open report ticket soon. I will ask some one work with me processing to everything complete then send later.
Many thank Gaia.
@everyone use Macintosh please contact me and work together and we will find out.