Page MenuHome

OUTLINER / No sorting by the selected object in complex projects with multiple collections within the collections
Closed, ArchivedPublic

Description

System Information
Operating system: Windows-10-10.0.17134 64 Bits
Graphics card: GeForce GTX 1070/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 419.17

Blender Version
Broken: version: 2.80 (sub 74), branch: master, commit date: 2019-07-11 13:44, hash: rB7ad21c3876c2
Worked: (on a "twoo week before" version )

Short description of error
[Wen I specify that I want to see only selected object at the first place in the outliner it doesn't show them. Just have to search it manually by srolling throuout hundreds of objects on the list. / I checked it out in a couple complex projects that I started on a version older by maybe a month. I've checked it on projects with many collections and it seems to stop sorting and showing selected objects like that only on this type of projects - the function is really useful only on that kind of projects. Well maybe I did something wrong with them? :P Normally on a small project it works ok.

]

Exact steps for others to reproduce the error
[Use a project with multiple objects and collections and collections within a collections. Select sorting by selected objects in the outliner, deselect collections just to see only selected object on the first place ]
[Based on the default startup or an attached .blend file (as simple as possible)]

Details

Type
Bug

Event Timeline

Germano Cavalcante (mano-wii) triaged this task as Needs Information from User priority.

I can not reproduce the bug. The selected object filter is working fine here.
Can you provide a .blend file showing the proplem?
Or, describe the steps in more detail from the default file.

Sorry, I can't make it... . The object apears but - not on the first place on the top of the list - like it used to, but all over the place with some other objects - not knowing why and where did they come from. :P You just still have to scroll and search it between those other objects. Its easier because the list is shorter yeah, but it doesn't work like it used to - always on the first place saving a lot of time. :( Check it out:

It is difficult to investigate the problem without being able to reproduce.
@Dalai Felinto (dfelinto), does the video indicate anything that can help to understand what is happening?

Hi @jeremy joe (blenderjoe) please provide a simple .blend file with specific instructions on how to reproduce the issue. Without that there is not much we can do.

Hi @Dalai Felinto (dfelinto) The problem is that in a simple blend file the bug doesn't ocure and I'm not able to send larger files that I refered to. Sorry. :/

@Dalai Felinto (dfelinto) Yes. It shows the problem :/ Maybe I didnt described it well sory :( Outliner doesn't show selected object (in 3D viewpot) on the top of the list like it used to show it. When it comes to changing visibility of an object - in render or in the viewport - you just use sorting by "selected object" and it normaly shows you what you want at the first place. This speeds up finding and disabling searched object in render or wherever you want. But Istead of showing selected object, it shows allso other objects on the list that aren't conected to it in any way. That makes it difficult to find listed object between other object that it shows even after specyfide search - "by selected object". The file on the film has a plenty of objects and on that kind of scale the bug ocures - at least I try to show that on film. Don't know if it helps :P

Bastien Montagne (mont29) closed this task as Archived.
Bastien Montagne (mont29) claimed this task.

If you cannot send original issue file, you should be able to recreate a dummy one reproducing the same problem. Or take original one, make a copy, remove all textures, replace all meshes with dummy cube, etc. There are always ways to make a production file useless/meaningless and hence shareable.

More than a week without reply or activity. Due to the policy of the tracker archiving for until required info/data are provided.