Page MenuHome

Blender 2.8 release candidate shows no available Cycles Render Devices
Closed, DuplicatePublic

Description

System Information
Operating system: MacOS 10.14.5
Graphics card: Radeon Pro 580 8GB

Blender Version
Broken in: Blender 2.80 2019-07-11 Release Candidate
Worked in this version: (optional) Blender 2.80 2019-07-09 3b4054cb586f

Short description of error
Installed the release candidate version of Blender 2.80.
The system settings shows no available Cycles Render Devices. The whole section for Cycles render devices is blank in the settings. No Cycles option on Scene/Render Engine properties settings.
The beta build from 2019-07-09 worked fine. The settings in the beta build shows options for 'NONE | CUDA | OPENCL'. While CUDA and OPENCL no longer work on my Mac (sigh)
the NONE option in this beta build works with CPU rendering just fine.

Exact steps for others to reproduce the error
Based on the default startup or an attached .blend file (as simple as possible).
I Re-downloaded and installed Blender 2.80 RC and got the same issue--no Cycles renderer

Details

Type
Bug

Event Timeline

LazyDodo (LazyDodo) closed this task as Archived.Jul 12 2019, 9:05 PM
LazyDodo (LazyDodo) claimed this task.

as noted in the release notes, opencl support has been dropped for mac

https://wiki.blender.org/wiki/Reference/Release_Notes/2.80/Cycles#GPU_rendering

You are misunderstanding the issue. The Cycles render engine basically DOES NOT EXIST in any form when I run the release candidate for Blender 2.80.
The settings page shows a header Cycles options but nothing else--the next line in the System settings is the header for Memory & Limits
The BETA 2.80 from two days previously--2019-07-09 allows me to use Cycles with the CPU. The settings page shows 'NONE | CUDA | OPENCL' settings under Cycles render options,
even though the CUDA and OPENCL options are not available for my Mac configuration.
The Release Candidate build for 2019-07-11 has no options for using Cycles whatever on my Mac.
This is a new problem that just appeared in the last two days.

The the issues has nothing to do with OPENCL or CUDA on the Mac.

John Hunt (jrh433) reopened this task as Open.Jul 12 2019, 9:21 PM

ah yes, that's a know issue, has been fixed, there should be a download link in T66754 while the new build synchronizes across the mirrors

@ jrh433 download new Blender 2.80RC1 for OSX check the problem again. It seems that Blender 2.80RC1 OSX has encountered problems that were corrected late this afternoon.