Page MenuHome

Add mesh: blenderkit asset library
Closed, ResolvedPublic

Description

System Information
Operating system: windows 10
Graphics card: 1080ti

Blender Version
Broken: add mesh: blenderkit asset library, doesnt show up in add mesh and when selected by using f3 has an error
2.8 release candidate

Worked: (optional)

error when opening and not in add mesh

just pressing f3 and searching for it and opening it

Event Timeline

You mean the Add menu in the viewport? Was that ever under Add > mesh in the Viewport? Never tried to use it that way, alsways used the n-panel.
The login doesn't seem to work properly with the RC. In the preferences it shows I am logged in, in the N-panel not. If I click on Login in the n-panel, it is stuck.
However, if you put in your API key in the preferences and login there, you can cancel the login in the n-panel, and the Kit works (and F3 works then too):

Brendon Murphy (meta-androcto) triaged this task as Waiting for Developer to Reproduce priority.

hi, not really a bug here but brought to my attention possible issues with blenderkit and search, it's worth investigating further.


I do think that under usual use case via the sidebar Blenderkit Tab, the addon works as expected.
@Vilem Duha (pildanovak) the above was caused using search and the thumbnail generator can you reproduce?

The issue was actually only the fact that the operator was exposed in F3 menu. It's hidden now. Second, autothumb operator now reports if the file wasn't saved and tells the user to save the file first.