Page MenuHome

Probleme with blender 2.8 UI
Closed, ArchivedPublic

Description

System Information
Operating system: Windows 7 Ultimate 64 bit (service pack 1)
Graphics card: ATI Mobility Radeon HD 4650

Blender Version
Broken: Blender v 2.8 Release Candidate

Short description of error
The UI and menus elements keeps flickering and glitching when the cursor moves.

Exact steps for others to reproduce the error
Here is a video showing the issue starting when blender 2.8 is launched
note: the reason for the long black screen is due to the recording software I'm using.

Details

Type
Bug

Event Timeline

It's possible that it's an OpenGL issue, your GPU is pretty old and if the data sheet I found is correct, it does not support OpenGL 3.3, which is required for Blender 2.80.
GCN architecture AMD cards and higher are needed to run 2.80.

@Benali (Darkussj) you can try updating to the latest driver version and check if the minimum hardware requirement is satisfied

https://code.blender.org/2019/04/supported-gpus-in-blender-2-80/

Hi thanks for the replies, as for my gpu its on a laptop so I can't swap it for another one and from the wiki link in the blender 2.8 requirements page it says that my gpu does support OpenGL 3.3 and compatible with blender 2.8.
as for the driver I do have the latest driver installed.


also I had this issue since blender 2.8 first introduced the new improved UI, but it got a bit better than it used over time this why I didn't report it as a bug I thought it would be fixed over time.

and thanks in advance.

@Benali (Darkussj) I searched for the specifications for your GPU card and I found that Radeon HD4650 has a maximum of 1G Vram on board, the minimum requirement for Blender is 2G Vram

sorry

Benali (Darkussj) added a comment.EditedJul 13 2019, 11:52 PM

@dark999 (dark999) ah man, but when I use dxdiag it says it has 2gigs and something, though I don't think the UI would consume 1Gig of vram let alone 2Gigs just on the startup file, the problem is only with the UI if I load a project the performance isn't bad to be honest just the continuous flickering of the UI that makes working with Blender 2.8 impossible, and like I mentioned before the flickering was worse when the new UI was first released.

and thanks in advance.

Brecht Van Lommel (brecht) claimed this task.

This graphics card is below our minimum requirements, OpenGL 3.3 is not sufficient, it must be GCN 1st gen or higher. We don't support it anymore.