Page MenuHome

Changing the Colorspace settings of a Movieclip is not properly updating Camera Background Images
Closed, ResolvedPublic

Description

System Information
Operating system: Linux-4.4.0-151-generic-x86_64-with-debian-stretch-sid 64 Bits
Graphics card: GeForce GTX 1080/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 430.26

Blender Version
Broken: version: 2.80 (sub 74), branch: master, commit date: 2019-07-12 17:50, hash: rBe3c586e262dd
Worked: (optional)

Short description of error
Changing the colorspace of Camera Background Images (in this case Movieclip) is not properly updating the display in the 3d viewport.
For example I load a sequence of EXR images in the Clip Editor and set that clip as source for Camera Background images.
If I now change the color space in the colorspace dropdown menu in the Camera Background Images panel, the colors of the clip in the clip editor change accordingly, but the colors of the background images in the 3d viewport stay the same.

Exact steps for others to reproduce the error
Let's take this file as an example:

Inititally the color space of the clip is set to Linear.
Now change the colorspace to e.g. Linear Aces (not that this would make much sense in this case, but as a demo).
The colors of the clip change, the colors of the image in 3d viewport do not.
However:
If you now press the button "Render Undistorted" in the camera background images panel, the colors in 3d view update.
If you disable the button again, the colors go back to the look they had before. I assume the 2 versions are cached somehow.
The thing is, if you now change the colorspace to Raw for instance, pressing "Render Undistorted" does not update the display of colors anymore.
So there is no reliable way to adjust the colorspace of background images.

What I assume would happen is that as soon as I change the colorspace, the internal cache is deleted and the view updated.