Page MenuHome

Blender 2.80 released candidate - help args module on python console.
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 8.1
Graphics card: NVIDIA 740M

Blender Version
Blender 2.80 released candidate
Broken: (example: 2.80, edbf15d3c044, master, 2018-11-28, as found on the splash screen)
Worked: (optional)

Short description of error
The python console cannot figure with help options ( modules)

To get a list of available modules, keywords, symbols, or topics, type
"modules", "keywords", "symbols", or "topics".  Each module also comes
with a one-line summary of what it does; to list the modules whose name
or summary contain a given string such as "spam", type "modules spam".


You are now leaving help and returning to the Python interpreter.
If you want to ask for help on a particular object directly from the
interpreter, you can type "help(object)".  Executing "help('string')"
has the same effect as typing a particular string at the help> prompt.

>>> help(modules)
Traceback (most recent call last):
  File "<blender_console>", line 1, in <module>
NameError: name 'modules' is not defined

Exact steps for others to reproduce the error
Based on the default startup or an attached .blend file (as simple as possible).

Details

Type
Bug

Event Timeline

You missed the quotation marks. It should be help('modules'), which works as expected.

Robert Guetzkow (rjg) closed this task as Invalid.Jul 13 2019, 7:49 PM
Robert Guetzkow (rjg) claimed this task.

You missed the quotation marks. It should be help('modules'), which works as expected.

Thank's. We can use all just with help() not like any python shell.

Robert Guetzkow (rjg) changed the task status from Invalid to Resolved.EditedThu, Jul 25, 10:46 AM

Corrected status to Resolved because Invalid is only meant for topics that shouldn't be one the bug tracker as described in the Phabricator wiki.