Page MenuHome

Blender-ID: Blender Hangs on login or logout
Closed, ResolvedPublic

Description

System Information
Operating system: Linux 64bit

Blender Version
Broken: 2.80 RC1

Short description of error
Blender became unresponsive after clicking the login button of the Blender-ID add-on.
There were no errors in the terminal.

Exact steps for others to reproduce the error
I only got this problem a few times, both on login and on logout, but not always.
After the initial problematic login, usually the add-on is correctly logging in or reporting an incorrect password.
I hadn't logged in for a while, so it could be some sort of token saving that only happens on first time? :/ I couldn't immediately see a pattern.
I managed to get the problem with and without preferences auto-save.
Somehow, the action does work, even if I had to kill the process, but the UI was completely unresponsive.

The actual steps are to insert the email and password and click the login button, or then the logout button.

Event Timeline

Interesting. On blender-2.80-83010c2f02e5-win64 it seems to be working.

I can't reproduce this bug on Manjaro Linux.
Btw, @Inês Almeida (brita_) , what distro are you using?

@CansecoGPC (CansecoGPC) I'm using Slackware, but I don't think that's related.

I can't reproduce this locally either, but it's been reported before (T66125).

Good that there are other reports. Note that I didn't see absolutely any output on the terminal, though.
I did check, there was nothing.

Yeah, it's the requests library that has infinity as the default timeout setting. So you will see a timeout, but only if you wait for infinity.