Page MenuHome

Lock camera to View - does not work correctly when camera parented
Closed, InvalidPublic

Description

System Information
Operating system: Win10
Graphics card: GTX 1080 and 1070

Blender Version
Broken: 2.80 (sub 74), branch: master, commit date: 2019-07-14 21:02, hash: 65168825e0b0, type: Release
Worked: (optional)

Short description of error


Lock camera to View - does not work correctly when it is paired to an object (not an object to this camera). behaves like this object was paired to the camera - and the opposite is true.

Exact steps for others to reproduce the error
Based on the default startup or an attached .blend file (as simple as possible).

Details

Type
Bug

Event Timeline

Duplicated on Windows 10 here. If the cube is the parent of the camera, then in Lock Camera to View mode moving the view moves the cube as if it were the child rather than the parent. The behavior is basically the same if you switch the parenting relationship but in that case, it's correct.

This is a feature enabled in Preferences -> Navigation -> Camera Parent Lock and was introduced in rBb2228633.
But it does not seem a good idea to affect this case.
@Campbell Barton (campbellbarton), feel free to close if it is not a valid bug.

Duplicated on Windows 10 here. If the cube is the parent of the camera, then in Lock Camera to View mode moving the view moves the cube as if it were the child rather than the parent. The behavior is basically the same if you switch the parenting relationship but in that case, it's correct.

I do not really understand what is correct? the camera is a child of a square. several other objects are also a square child. Somehow the camera moves the remaining children and the square - a square to which everything is attached (!)
This problem only occurred to me in the more complex work. When I tried to do it on a simple block everything worked ok.

This is a feature enabled in Preferences -> Navigation -> Camera Parent Lock and was introduced in rBb2228633.
But it does not seem a good idea to affect this case.
@Campbell Barton (campbellbarton), feel free to close if it is not a valid bug.

ok, now understand - plz fix (that is not good idea to work in that way) and close

Campbell Barton (campbellbarton) closed this task as Invalid.EditedJul 16 2019, 4:37 AM

Closing since this is working as intended, if you propose to change preferences default, see: T54943