Page MenuHome

Crashes when mirror hair
Closed, ArchivedPublic

Description

System Information
Operating system: Windows 10
Graphics card: 2x gtx 1080

Blender Version
RC 2.8

Crashes when trying to mirror hair

To be 100% the mesh is exacly the same, i deleted the left side and mirroed it, disconnected the connected hairs first. Then reconnected them, and deleted the left side.
Now i selected all the hairs on the right side and clicked "mirror" and then blender just closes, no error messages or anything. tryied it on the 6 prevoius versions but it just died on everyone of them.

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) triaged this task as Needs Information from User priority.

Hi and thx for the report.
Not sure I follow "i deleted the left side and mirroed it, disconnected the connected hairs first. Then reconnected them, and deleted the left side" exactly.

  • Do you mind just sharing a .blend file where this happens prior to mirror/crash [this just ensure we are all on the same page...]?
  • Also: we are talking about Particle > Mirror (in Particle Edit mode), right?
Johan Ryberg (Ryberg) closed this task as Resolved.Jul 16 2019, 1:27 PM
Johan Ryberg (Ryberg) claimed this task.

Hello ! I solved it. or well founded out why it crashed atlesat. My headmesh wasent at 0 on the x axel , so when i tryied to mirror it blender crashed. When I then took the head mesh to 0 on the x axel and then tryied to mirror it, it worked no problem.

When I said I delted the left side i meant of the mesh, and mirrored the mesh so I would have to identical sides. and if u delete or alter the mesh when having hair connected it will mess the hair up, so u have to "disconnect" the hair first and then do that action and then reconnect it.

and yes it crashed when trying to mirror hairparticles.

Philipp Oeser (lichtwerk) removed Johan Ryberg (Ryberg) as the assignee of this task.

Glad you found a solution.

However others might run into the same situation, and blender shouldnt be crashing here...
Still would appreciate if you could share the file (that was crashing) prior to mirroring, so we can fix this for others as well -- love for everyone here :)

Thx in advance!

Demeter Dzadik (Mets) closed this task as Archived.
Demeter Dzadik (Mets) claimed this task.

Hm, closing this for now due to no response in a week, but like Philip said, it'd be great if you could attach a blend file, so we could reproduce on our end and maybe someone could fix the crash. You can still post here even though it's closed, if we can reproduce it then it could be re-opened.