Page MenuHome

Issue in hair particles.
Closed, ArchivedPublic

Description

System Information
Operating system: - WINDOWS 10.
Graphics card: AMD RADEON RX580 8GB SAPPHIRE NITRO+ EDITION

Blender Version
Broken: BLENDER 2.8 RELEASE CANDIDATE -- blender-2.80rc1-windows64

Short description of error
When using hair particles on a mesh that has modifiers, sometimes the "Use Modifier Stack" option does not function even when checked.

Exact steps for others to reproduce the error
Based on the default startup or an attached .blend file (as simple as possible).

1 Opened Blender

2 Modelled a broom from default cube, using subsurf modifier to get rounded feel, but not applying it.

3 Made vertex groups for hair density

4 made 3 hair particle systems, edited settings (Including "Use Modifier Stack" Option.)

5 Combed and cut hair in particle edit mode to satisfaction.

6 Rendered a quick image to find hair behaving sporadic.

7 Tried for a few hours to figure out what went wrong.

8 Applied subsurf modifier and then rendered fine.

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Jul 16 2019, 3:15 PM

Did the subdivision modifier have the same subdivisions set for both viewport and render? (this is required to let Use Modifier Stack work correctly)?

If that doesnt fix the issue: could you share your .blend file for further inspection here?

Could use clarification on 6. "Rendered a quick image to find hair behaving sporadic."
Very well, you are seeing something wrong but the phrasing of step 6. doesn't visualize the issue.
A picture is worth a thousand words, and all that.
Better yet, a .blend file with steps to recreate what you are seeing. Could you post one, please? With steps that lead to this "sporadic" behavior? Thank you!
Insofar as particle behavior being set by vertex groups, this reports shares similarities with T63166, but there is not enough information to declare that one is a duplicate of the other.

Could use clarification on 6. "Rendered a quick image to find hair behaving sporadic."
Very well, you are seeing something wrong but the phrasing of step 6. doesn't visualize the issue.
A picture is worth a thousand words, and all that.
Better yet, a .blend file with steps to recreate what you are seeing. Could you post one, please? With steps that lead to this "sporadic" behavior? Thank you!
Insofar as particle behavior being set by vertex groups, this reports shares similarities with T63166, but there is not enough information to declare that one is a duplicate of the other.

Sure, I can add an image from my viewport and the render here.

The quick image I rendered was just a low resolution render without many materials or lighting.
Applying my subsurf did simply fix the problem instantly even though the use modifier stack box was checked on my particle systems.

How would I upload the .blend file properly?

Did the subdivision modifier have the same subdivisions set for both viewport and render? (this is required to let Use Modifier Stack work correctly)?
If that doesnt fix the issue: could you share your .blend file for further inspection here?

The modifier was the same yes.

How would I upload the .blend file properly?

On the control panel header of the text editor box where you type comments there is a little black cloud icon with a white upward pointing arrow on it - next to the last on the the left hand side.
Click on that; your browser should initiate a file upload session. Click on the browse for file (or some such wording) and navigate to your .blend file and choose it.
You should be good to go.
Thank you for the picture - this helps narrow matters for me.

How would I upload the .blend file properly?

On the control panel header of the text editor box where you type comments there is a little black cloud icon with a white upward pointing arrow on it - next to the last on the the left hand side.
Click on that; your browser should initiate a file upload session. Click on the browse for file (or some such wording) and navigate to your .blend file and choose it.
You should be good to go.
Thank you for the picture - this helps narrow matters for me.

Hey would my blend file still be needed even though I fixed the problem for myself? I don't really want to go to my work and re-ruin it to be able to send the right thing needed.

@George Simister (AnaxondA): If you fixed the problem for yourself, then that is great!
If, in the course of fixing the problem yourself, you migrated away from the circumstances that created the bug - and you can't get back to those circumstances easily in a non-destructive way - then c'est la vie...
Bug fixing mainly depends on a file and procedure that reliably recreates a problem. That establishes the all-important anchor point to start an investigation. In the absence of that, it's mostly time-consuming guesswork that leads to little in the way of profitable results.
This bug report will stay around for awhile in a "Need information..." state. If you happen to rediscover the bug, then post the blend file here and a decent, brief, narrative of how you arrived at the circumstances of the bug. Otherwise, this report will be closed at some point because it offers no useful investigative starting point. Thanks for reporting!

Demeter Dzadik (Mets) closed this task as Archived.Jul 28 2019, 1:04 AM
Demeter Dzadik (Mets) claimed this task.

Closing now due to what Garry explained. Feel free to re-open if you manage to reproduce the bug again.