Page MenuHome

The delete key deletes keymap entries
Closed, ArchivedPublic

Description

System Information
Operating system: Windows-10-10.0.17134 64 Bits
Graphics card: Quadro P4000/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 397.44

Blender Version
Broken: version: 2.80 (sub 74), branch: master, commit date: 2019-07-11 13:50, hash: rB06312c6d2db8
Worked: (optional)

Short description of error
Pressing the delete key in the keymap editor deletes the entry even when you are in the "Press a key" mode. So instead of the delete key being assigned to the Keymap entry, the entry is deleted. This makes it impossible to assign the delete key to a keymap in Blender 2.8 unless the functionality exists somewhere else in the interface like a menu.

The keymap for the keymap editor can't be edited as far as I can tell, so I can't change this behavior myself.

Exact steps for others to reproduce the error
Open Preferences editor. Go to the Keymap tab. Find an entry of the "Keyboard" type of event mapping. Click the assignment button and press the delete key. The entire entry disappears.

Details

Type
Bug

Event Timeline

System Information
Operating system: Windows-10-10.0.18362 64 Bits
Graphics card: GeForce GTX 960/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 431.36

Blender Version
Broken: version: 2.80 (sub 74), branch: master, commit date: 2019-07-11 13:50, hash: rB06312c6d2db8

On my system there is also a problem with Del/backspace, but it happens not the same way as described above by @Dan Pool (dpdp). If I choose a key, that is binded to "Delete" and try to assign the "Back Space" key, the entry disappears, but not if I press the "Delete" key.
And it is vice versa, on the key binding of a command which uses Back Space it disappears when I press "Delete", but not if I press Backspace again. Happens on both the german and the english keyboard layout (set in Win OS).

If a command is not binded to delete or back space, everything is okay, with both:

Germano Cavalcante (mano-wii) triaged this task as Needs Information from User priority.

It's working fine on my tests.
This report reminded me of this other T67043: can't add more then 4 custom keymap
Make sure you are not creating the same keymaps, as they come together into one.

@Germano Cavalcante (mano-wii)
I wasn't creating a new keymap, just tried to change an existing one to check if I can reproduce the bug. You can see that in the 1st gif. Or did I something wrong with that?

I wasn't creating a new keymap, just tried to change an existing one to check if I can reproduce the bug. You can see that in the 1st gif. Or did I something wrong with that?

In your case what happened was that when you changed the key, the keymap no longer matched the specified Key-Binding filter you typed ("del").

But I recognize that these immediate updates are confusing and nuisance. It's something that needs to be investigated.

That may be the same issue I was having. I may have been searching for the key-binding delete instead of name delete, because I'm no longer having the issue. Sorry for the bad report. It looks like user error.

I will say that I've run into issues with this behavior in the past. It seems like it would be more user-friendly if the search results remained after changing the keybinding. As it stands now, if you search for an item and then change the key-binding, you have to search for it again to continue editing the keymap entry.

In general, the keymap editor needs some love. A single drop down that lets you filter the list based on context would do wonders. This would be similar to the filter in the addons editor: All, 3d View, Window, Screen, Node Editor, etc.

Bastien Montagne (mont29) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Mon, Jul 29, 6:34 PM
Jacques Lucke (JacquesLucke) closed this task as Archived.
Jacques Lucke (JacquesLucke) claimed this task.

I don't really see a bug here. It's not really nice behavior but let's hope that this is solved by a larger keymap editor rewrite at some point.