Page MenuHome

Segmentation fault: 11 Crash
Closed, ArchivedPublic

Description

System Information
Operating system: Mac OS
Graphics card: AMD FirePro D700 6 GB

Blender Version
Broken: 2.80, Release Candidate

When In edit mode and in orthographic view if you rotate or move a group of verts the program crashes. Segmentation fault: 11?

Terminal output:

Last login: Tue Jul  9 10:03:27 on ttys000
Quarter-Pounder-2294:~ Graphics2$ /Applications/Blender.app/Contents/MacOS/Blender ; exit;
Read prefs: /Users/Graphics2/Library/Application Support/Blender/2.80/config/userpref.blend
found bundled python: /Applications/Blender.app/Contents/Resources/2.80/python
register
register_class(...):
Warning: 'ga.generate' doesn't contain '_PT_' with prefix & suffix
register_class(...):
Warning: 'ga.advanced' doesn't contain '_PT_' with prefix & suffix
register_class(...):
Warning: 'ga.tools' doesn't contain '_PT_' with prefix & suffix
------------------------------
Warning: class matlibMaterials contains a property which should be an annotation!
/Users/Graphics2/Library/Application Support/Blender/2.80/scripts/addons/materials_library-master/__init__.py:136
    assign as a type annotation: matlibMaterials.category
Warning: class matlibProperties contains a property which should be an annotation!
/Users/Graphics2/Library/Application Support/Blender/2.80/scripts/addons/materials_library-master/__init__.py:708
    assign as a type annotation: matlibProperties.lib_index
    assign as a type annotation: matlibProperties.all_materials
    assign as a type annotation: matlibProperties.materials
    assign as a type annotation: matlibProperties.mat_index
    assign as a type annotation: matlibProperties.categories
    assign as a type annotation: matlibProperties.cat_index
    assign as a type annotation: matlibProperties.search
    assign as a type annotation: matlibProperties.link
    assign as a type annotation: matlibProperties.force_import
    assign as a type annotation: matlibProperties.filter
    assign as a type annotation: matlibProperties.show_prefs
    assign as a type annotation: matlibProperties.last_selected
    assign as a type annotation: matlibProperties.hide_search
Traceback (most recent call last):
  File "/Applications/Blender.app/Contents/Resources/2.80/scripts/modules/addon_utils.py", line 351, in enable
    mod = __import__(module_name)
ModuleNotFoundError: No module named 'InstantMeshesRemesh_bl_two_eight'
Traceback (most recent call last):
  File "/Applications/Blender.app/Contents/Resources/2.80/scripts/modules/addon_utils.py", line 351, in enable
    mod = __import__(module_name)
ModuleNotFoundError: No module named 'InstantMeshesBridge_Updated'
register_class(...):
Warning: 'FontSelectorPanel' doesn't contain '_PT_' with prefix & suffix
register_class(...):
Warning: 'FontUIList' doesn't contain '_UL_' with prefix & suffix
Loading MakeWalk
MakeWalk loaded
Warning: class FSPY_BLENDER_OT_import_project contains a property which should be an annotation!
/Users/Graphics2/Library/Application Support/Blender/2.80/scripts/addons/fspy_blender/__init__.py:50
    assign as a type annotation: FSPY_BLENDER_OT_import_project.filter_glob
    assign as a type annotation: FSPY_BLENDER_OT_import_project.update_existing_camera
    assign as a type annotation: FSPY_BLENDER_OT_import_project.import_background_image
register_class(...):
Warning: 'Armature_PT_jiggle' doesn't have upper case alpha-numeric prefix
register_class(...):
Warning: 'Scene_PT_jiggle' doesn't have upper case alpha-numeric prefix
register_class(...):
Warning: 'Bone_PT_jiggle_bone' doesn't have upper case alpha-numeric prefix
Font Selector --- Font Folders Up to Date
Font Selector --- Settings Loaded
Read blend: /Volumes/Creative2/1_GRAPHICS SERVER/1_Graphics 2019/07 July/Doc/DOC-07191-AnimationSet2/Doc_Man_Rigged.blend
Font Selector --- Font Folders Up to Date
Font Selector --- Settings Loaded
Writing: /var/folders/9x/l_w6frnd7vx4b47bj7phpksh0000gn/T/Doc_Man_Rigged.crash.txt
Segmentation fault: 11
logout
Saving session...
...copying shared history...
...saving history...truncating history files...
...completed.
Deleting expired sessions...none found.

[Process completed]

Details

Type
Bug

Related Objects

Event Timeline

i can not reproduce this bug on OpenSUSE Tumbleweed linux CPU AMD FX8350 16G ram, GPU Nvidia 690

upload simplest .blend file can help

Dalai Felinto (dfelinto) triaged this task as Needs Information from User priority.

Please try with --factory-startup from command line or from the menu: File > Defaults > Load Factory Settings.
The problem you are having seems to be coming from one of the addons you have installed.

Demeter Dzadik (Mets) closed this task as Archived.
Demeter Dzadik (Mets) claimed this task.

Closing due to no response in a week. Feel free to re-open if Dalai's suggestion didn't solve the issue and it still persists on the latest build.