Page MenuHome

SAVE CRASH
Closed, ArchivedPublic

Description

System Information
Operating system: Windows 10
Graphics card: Radeon R5 M230 2GB

Blender Version
Broken: 2.8 Realease Candidate
Worked: (optional)

Every time I try to save the program crash.

Exact steps for others to reproduce the error
when I try to save a project the program suddenly closes. Sometimes it happens the second time I open the project.

Details

Type
Bug

Event Timeline

Hi, does this happen with every file or only with a specific project of yours?

claudio (theclod4) added a comment.EditedJul 18 2019, 12:41 AM

happens with all files, even with a newly opened one. ( I can't save the project but I can export it )

claudio (theclod4) added a comment.EditedJul 18 2019, 1:02 AM

no i was wrong. I can export the file but when I open it again, it's all wrong.

claudio (theclod4) added a comment.EditedJul 18 2019, 1:14 AM

I tried doing a project with blender 2.8 beta. when I append him a scene from another blender 2.8 beta project, everything is fine. But if I append a scene of a blender 2.8 RC project, then if I try to save everything crash.

Sybren A. Stüvel (sybren) triaged this task as Needs Information from User priority.

Update your display drivers to the latest version, and try the latest daily build from https://builder.blender.org/download/ to see if it hasn't been fixed yet.

nope....keep closing when I try to save the project the second time

Which exact version of Blender are you using, and which display drivers?

If you start Blender via Run cmd.exe, then

cd c:\<blender installation directory>
blender

Do you see any messages in the terminal window?

Blender 2.80 Release Candidate
AMD radeon (TM) R5 M230 2GB
Intel(R) HD graphics family

C:\Users\sebastian\Desktop\blender-2.80rc1-windows64>
C:\Users\sebastian\Desktop\blender-2.80rc1-windows64>blender
Read prefs: C:\Users\sebastian\AppData\Roaming\Blender Foundation\Blender\2.80\config\userpref.blend
AL lib: (EE) UpdateDeviceParams: Failed to set 48000hz, got 44100hz instead
found bundled python: C:\Users\sebastian\Desktop\blender-2.80rc1-windows64\2.80\python

Blender 2.80 Release Candidate

As I said, try the latest daily build from https://builder.blender.org/download/ to see if it hasn't been fixed yet.

@claudio (theclod4) in the previous comment you only posted what happens in the command line when blender starts, there should also be a message when it closes.
In the build folder you downloaded there is a cmd file called blender_debug_log.cmd; that will start Blender and when it crashes it will automatically save a log file that you can post here.

here are the two log file. But when I open the same project with blender_debug_log.cmd i can save. Then when I open it again it normally the project crash when I save.

Then the crash is most likely due to your user preferences or your installed addons somehow.

When you posted this:

C:\Users\sebastian\Desktop\blender-2.80rc1-windows64>
C:\Users\sebastian\Desktop\blender-2.80rc1-windows64>blender
Read prefs: C:\Users\sebastian\AppData\Roaming\Blender Foundation\Blender\2.80\config\userpref.blend
AL lib: (EE) UpdateDeviceParams: Failed to set 48000hz, got 44100hz instead
found bundled python: C:\Users\sebastian\Desktop\blender-2.80rc1-windows64\2.80\python

Wasn't there anything else after? And did you follow exactly what Sybren said?
It's important that you open Blender from a terminal, not toggling it from the Window menu after it started. This allows you to see the closing message if any.

Otherwise you might try to isolate the problem by removing your addons and custom shortcut one by one until you find out where it is.

Otherwise you might try to isolate the problem by removing your addons and custom shortcut one by one until you find out where it is.

Starting with factory defaults (blender.exe --factory-startup) is an easier way to test this. If that works you know that it's either a setting or an add-on, and you can continue the investigation from there.

when i start blender with factory defaults i have this message :

AL lib: (EE) UpdateDeviceParams: Failed to set 48000hz, got 44100hz instead
found bundled python: C:\Users\sebastian\Desktop\blender-2.80.0-git.5f140e61c28c-windows64\2.80\python
Saved session recovery to 'C:\Users\SEBAST~1\AppData\Local\Temp\quit.blend'
fake_module: addon missing 'bl_info' gives bad performance!: 'C:\\Users\\sebastian\\AppData\\Roaming\\Blender Foundation\\Blender\\2.80\\scripts\\addons\\GoB.py'
fake_module: addon missing 'bl_info' gives bad performance!: 'C:\\Users\\sebastian\\AppData\\Roaming\\Blender Foundation\\Blender\\2.80\\scripts\\addons\\bfu_Basics.py'
fake_module: addon missing 'bl_info' gives bad performance!: 'C:\\Users\\sebastian\\AppData\\Roaming\\Blender Foundation\\Blender\\2.80\\scripts\\addons\\bfu_WriteImportSequencerScript.py'

Blender quit

i remove the addons GOB.py from the add screen on blender but continues to close.

Bastien Montagne (mont29) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Mon, Jul 29, 6:24 PM
Sebastian Parborg (zeddb) triaged this task as Needs Information from User priority.

Does this still happen with the latest blender beta? https://builder.blender.org/download/

Still believe this is caused by an Addon (not sure about the fake_module message above).
Could you just (temporarily) rename the addons folder and see if this improves the situation?

Bastien Montagne (mont29) closed this task as Archived.
Bastien Montagne (mont29) claimed this task.

More than a week without reply or activity. Due to the policy of the tracker archiving for until required info/data are provided.