Page MenuHome

GPU Hair Rendering Bug - "Glitter" with particular Root to Tip sizes
Open, Confirmed, MediumPublic

Description

System Information
Operating system: Windows-7-6.1.7601-SP1 64 Bits
Graphics card: GeForce RTX 2070/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 430.64

Blender Version
Broken: version: 2.80 (sub 74), branch: master, commit date: 2019-07-11 13:50, hash: rB06312c6d2db8
Worked: (optional)

Short description of error
In a perfect storm of GPU rendering + Hair with Radius Root size smaller or equal to the Tip size, bright white "cards" appear at the tips of some hair strands.

Switching to CPU rendering, the anomalies go away.

Also, making the Root size Large and the Tip size small reduces the cards, but they are still there.

Exact steps for others to reproduce the error

Open the attached file in Blender 2.80
Switch to the Camera view if not already there
Render (should be set to Cycles using GPU)
Switch to Cycles using CPU rendering
Render

Optionally:

Select the hair object (eyebrows)
Go to the particle tab
Under Hair Shape, change the Radius Root to, say, 0.45 and the Tip to 0.1
Render using GPU - cards are still there but are much smaller.

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) triaged this task as Confirmed, Medium priority.

Can confirm.
Interestingly, this happens on CPU for me as well (Intel® Core™ i7-6700 CPU @ 3.40GHz × 8).
Also, for me, changing Root Radius has no affect on the size of the "cards".

@Brecht Van Lommel (brecht): mind checking? CC @Sergey Sharybin (sergey)