Page MenuHome

Extrude Acting Like Move - 2.79
Closed, ArchivedPublic

Description

System Information
Operating system: Windows 10
Graphics card: GTX 1080 Laptop Edition

Blender Version
Broken: 2.79, f4dc9f9d68b, master, 2018-03-22, as found on the splash screen

Short description of error
Whenever I attempt to use extrude (hotkey or sidebar), it acts as if I am using the move tool (G). In various attempts, G, also acts like E. Overall, I can't get it to extrude properly. This is while attempting to extrude an open circle mesh after creating it. Usually, the first time you attempt it it works fine, then after that, it stops working in that project file. You have to open a new project in order for it to work again as expected. Here is another user who apparently is having a similar problem in 2.8, though not entirely the same. https://blender.stackexchange.com/questions/139969/extrude-acting-like-move-blender-2-8?rq=1
His suggested workaround isn't working for me.

Exact steps for others to reproduce the error
Open the attached .blend file, Create a circle mesh and attempt to extrude.

Details

Type
Bug

Event Timeline

@Justice Goble (jboogsthethug) 2.7 bugs aren't really being fixed anymore. I recommend trying out the 2.80 Release Candidate, and if you still run into this bug, let us know.

That said, when I open your file in 2.80 and I spawn a circle, attempting to extrude it indeed acts like Grab. Switching from Edge to Vertex select mode seems to fix it. Soooo maybe it is a 2.80 bug after all. I think an important question would be, can you get a file to this bugged state, starting out from a 2.80 startup file?

System Information
Operating system: Windows-10-10.0.18362 64 Bits
Graphics card: GeForce GTX 960/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 431.36

version: 2.79 (sub 0), branch: master, commit date: 2018-03-22 14:10, hash: f4dc9f9d68b

I can't reproduce the bug in 2.79. everything works fine:

Oh wait a second, it's in face select mode by default not edge select! Okay, so trying to extrude geometry while you're in face select mode, when you don't actually have any faces, causes it to behave like Grab.

Why are we able to select edges while we're in face select mode in the first place? (This can happen either when spawning a new object, which will have the edges selected by default, or simply using Select All) Is this on purpose? We cannot select verts in edge mode when there are no edges.

While there might be a bug here(A developer will pop up and decide), the solution to your problem for now at least, is to make sure you're in vertex or edge select mode while extruding @Justice Goble (jboogsthethug)

Thanks for all the quick responses. I didn't realize 2.7 bugs aren't being fixed so good to know, I downloaded 2.8 to test out. You are correct about the edge select mode needing to be activated! I didn't even think to switch that, good call. I'll plan on switching to 2.8 though. I was waiting for the full version to be released but after pulling it up I am intrigued at the interface and I'm looking forward to the switch! I Especially like the click on and off, that's awesome! Thanks for your hard work and again for the quick response!

Germano Cavalcante (mano-wii) closed this task as Archived.

From the comments it seems like this is just a usability issue that needs to be improved, but not a bug.

work fine for me Linux Blender RC2 AMD FX8350 16G ram, GTX 690 nvidia 430.34
In edit mode you have select face mode, you had created circle with not face, if you switch to edges or vertices selection extrude work fine