Page MenuHome

`Text` Object -> `Tab` Key For Indenting Not Working
Closed, InvalidPublic

Description

System Information
Operating system: Windows-10-10.0.17134 64 Bits
Graphics card: AMD Radeon HD 8400 / R3 Series ATI Technologies Inc. 4.5.13399 Core Profile Context 15.200.1065.0

Blender Version
Broken: version: 2.80 (sub 74), branch: master, commit date: 2019-07-18 14:52, hash: rB38d4483c6a51
Worked: (optional)

Short description of error
For Text Object Using Tab Key for Indenting (Normally 4 / 2 spaces) Not working as in many text editors support as It switch to Object Mode.

Exact steps for others to reproduce the error

  1. Create a Simple Text Object
  2. Switch to Edit Mode
  3. Press Tab Key
  4. It will switch to edit mode rather then adding Tab (indent) as in many text editor...

Details

Type
Bug

Event Timeline

I can confirm on linux RC2, but 2.79b work same. IMO This is not a regression or bug, it may be a feature request

Ulysse Martin (youle) closed this task as Invalid.
Ulysse Martin (youle) claimed this task.

I don't think it can be considered as a bug. TAB key has always been set to switch between edit mode and object mode, and a text object can't really be considered as a full text editor. Tabulations can be replaced with spaces eventually. As this is not a bug, and in order to try to keep the bug tracker with high priority tasks, I take the liberty to tag this report as invalid.