Page MenuHome

Ctrl+Z does not restore deleted node in shader editor
Closed, ResolvedPublic

Description

System Information
Operating system: Linux-4.15.0-54-generic-x86_64-with-debian-buster-sid 64 Bits
Graphics card: GeForce GTX 1070/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 390.116

Blender Version
Broken: version: 2.80 (sub 74), branch: master, commit date: 2019-07-18 14:52, hash: rB38d4483c6a51
Worked: (optional)

Short description of error
Ctrl+Z does not restore deleted node in shader editor

Exact steps for others to reproduce the error
Following this tutorial https://www.youtube.com/watch?v=0zrd37k2tJM&list=PLa1F2ddGya_-UvuAqHAksYnB0qL9yWDO6&index=17
I've deleted the MixRGB node, then wanted it to be back by pressing CTRL+Z, but it's not restoring the node, I also tried with other nodes, same result.
I noticed that when I press CTRL+Z the 3D viewport is switching to wireframe mode which is done because of the Z key, maybe it's related to the bug ?

Details

Type
Bug

Event Timeline

I'm not having any problems here on Windows with that node setup. Are you sure you have the mouse cursor over the shader editor when you're pressing CTRL-Z?

I do note that if I delete the default Principled BSDF node in the shader editor and then click five times on the node editor background, I then have to undo six times to get the deleted node back since each click stacked a meaningless deselect operation. Seems like there's potentially some room for improvement here, but it's not really a bug. It does point out that sometimes you need to CTRL-Z more times than you might expect in order to get back to where you want to be.

Bastien Montagne (mont29) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Jul 20 2019, 4:22 PM
Karl STEIN (jalik) added a comment.EditedJul 22 2019, 7:50 PM

Indeed, I tried on Windows 10 and the problem is not present, it seems to affect only Linux version.

I did CTRL+Z multiple times, nothing happen, even the previous selected node is not selected again, so I can confirm the undo is broken.
The mouse was over the shader editor of course, I also clicked into it to give it focus (just in case of).
On Linux I can reproduce the bug every time.

Edit: Not sure if this is useful, but I am using AZERTY keyboard, so the Z key is where the W key is on a QWERTY keyboard.

Gavin Scott (Zoot) raised the priority of this task from Needs Information from User to Waiting for Developer to Reproduce.Jul 23 2019, 12:33 AM

Hello guys, after downloading and running the RC3, it seems that the bug was resolved, did you fix it ?

Philipp Oeser (lichtwerk) closed this task as Resolved.Mon, Sep 23, 2:32 PM
Philipp Oeser (lichtwerk) claimed this task.

This indeed seems fixed (havent hunted down the particular commit, but there were some regarding Undo).

Will close this report, feel free to comment again if issues arise again...