Page MenuHome

Chinese characters do not appear
Closed, ArchivedPublic

Description

System Information
Operating system: Darwin-17.7.0-x86_64-i386-64bit 64 Bits
Graphics card: Intel(R) Iris(TM) Graphics 550 Intel Inc. 4.1 INTEL-10.36.25

Blender Version
Broken: version: 2.80 (sub 74), branch: master, commit date: 2019-07-18 14:52, hash: rB38d4483c6a51
Worked: (optional)

Short description of error
Chinese characters display error

Exact steps for others to reproduce the error
[Please describe the exact steps needed to reproduce the issue]
[Based on the default startup or an attached .blend file (as simple as possible)]

Details

Type
Bug

Event Timeline

@zhaoyunlai (lyman) You need to activate "Translation" in User Preferences > Interface for this, you can then keep it in English by leaving every option unselected, if you want so.

@Bastien Montagne (mont29) this is by design right?

Bastien Montagne (mont29) closed this task as Archived.Jul 20 2019, 8:12 PM
Bastien Montagne (mont29) claimed this task.

Yes, default Blender font embedded in Blender only has some ASCII axtended chars, for performances reasons. To get full (or nearly) unicode char set, you can either enable Translation setting, or chose your own Interface Font in the user preferences.