Page MenuHome

problem with custom ocio
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-10-10.0.17134 64 Bits
Graphics card: GeForce GTX 1060 6GB/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 398.36

Blender Version
Broken: version: 2.80 (sub 74), branch: master, commit date: 2019-07-18 14:52, hash: rB38d4483c6a51

Short description of error
Using a custom location for config.ocio results in fail to start
If I set the "OCIO" env variable to the current location of Blender's config.ocio it launches fine. If I put the same config.ocio file in a different location on disk and point the "OCIO" variable to that location Blender will not launch. No errors are written to the console.

Exact steps for others to reproduce the error
Using the command prompt ...

  • copy config.ocio from .\blender\blender-2.80rc2-windows64\2.80\datafiles\colormanagement\config.ocio to c:\temp
  • I navigate to the blender location,

C:\Program Files (other)\blender\blender-2.80rc2-windows64

  • set the OCIO environment variable,

Set "OCIO=C:\temp\config.ocio"

  • run Blender,

C:\Program Files (other)\blender\blender-2.80rc2-windows64>blender

OUTPUT:
Color management: Using C:\temp\config.ocio as a configuration file

After which the command prompt receives focus back since Blender seems to cancel it's launch.

Details

Type
Bug

Event Timeline

Hi @Tom Voll (tjvoll)

It is working for me with aces 1.0.3 ocio config.
Can you add more details to this issue. For example what is the content of the environment variable or what is ocio config you are loading.
Where did you configure the environment variable how do you start blender.

We need exact steps and detail to be able to reproduce issues. If we are not able to reproduce the issue, it will be really hard to guess what is going on :)

Jeroen Bakker (jbakker) triaged this task as Needs Information from User priority.Jul 23 2019, 8:56 AM

I've update the description with more explicit steps to reproduce.

Tom Voll (tjvoll) raised the priority of this task from Needs Information from User to Waiting for Developer to Reproduce.Jul 24 2019, 11:01 PM

Just to be sure. you are only copying the config file, but not all the related files that are referred by the config file?
If I do that I get the error that the config file is corrupt

jeroen@jeroen:~/blender-git/blender$ OCIO=/home/jeroen/blender-git/config.ocio b280
Color management: Using /home/jeroen/blender-git/config.ocio as a configuration file
terminate called after throwing an instance of 'OpenColorIO::v1::ExceptionMissingFile'
  what():  The specified file reference  'srgb_to_xyz.spimtx' could not be located. The following attempts were made: /home/jeroen/blender-git/luts/srgb_to_xyz.spimtx : /home/jeroen/blender-git/filmic/srgb_to_xyz.spimtx
Aborted (core dumped)

When I copy over the whole configuration (including the luts and filmic) Blender just starts on my system.

Tom Voll (tjvoll) closed this task as Resolved.Jul 25 2019, 8:26 PM
Tom Voll (tjvoll) claimed this task.

Ah, okay that was it. Thank you very much for your help.