Page MenuHome

Colormanagement "Look"-Settings don't get promoted when appending Scene from 2.79
Closed, ArchivedPublic

Description

Operating system: win10
Graphics card: GTX 980

version: 2.80 (sub 75), branch: master, commit date: 2019-07-25 14:34, hash: cb10bd379b2d, type: Release
build date: 25/07/2019, 17:04
platform: Window

When importing Scene from 2.79 "look"-settings under Colormanagement don't get promoted to 2.8

-Create a scene in 2.79 change the Look under Colormanagement to something else than "none", e.g. "Very High Contrast"
-Save the File
-In 2.8 append Scene from before saved File - "Look" is set to "none"...

Details

Type
Bug

Event Timeline

Germano Cavalcante (mano-wii) triaged this task as Confirmed, Low priority.

I can confirm.
Scenes saved in 2.8 do not have this problem.
It should be a versioning issue.

Thing here is: the color management changed quite a bit in 2.80, and it's not always possible to preserve it 1:1 due to some looks removed, some renamed and so on.

@Brecht Van Lommel (brecht), do you think we should try doing hardcoded-strings-comparison in do-version to try preserving compatibility better? Not sure how i feel about it. It'll be the only way to go, but it could still fail.

Brecht Van Lommel (brecht) closed this task as Archived.Thu, Aug 1, 7:38 PM

I don't think it's worth spending time to improve backwards compatibility here. Exact backwards compatibility is not possible anyway due to the various color management changes.