Page MenuHome

Time Remapping - animation does not conform to new timeframe
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 10
Graphics card: NVidia 980

Blender Version
Broken:
2.80, Git-a49838ccb0f6-28-Jul
Worked: (optional)
previous releases

Short description of error
Time Remaping in properties not working.

Exact steps for others to reproduce the error

Change the value of Time Remapping - animation does not conform to new timeframe.

Event Timeline

William Reynish (billreynish) triaged this task as Needs Information from User priority.

I cannot reproduce this. Time Remapping appears to work normally here.

Does it work differently between 2.7x and 2.8 for you?

Time remapping is not changing time of animations now.
Normally if I keyframed something from frame 1 to 10 and than did time remmaping (change 100 to 200) animation would last 20 frames, but it is not so now. It still animatefor 10 frames.
Problem appeared few days ago. All previous daily builds and 2.79 were fine.

William Reynish (billreynish) raised the priority of this task from Needs Information from User to Waiting for Developer to Reproduce.Mon, Jul 29, 3:01 PM

Example of animation lasting 10 frames where with TR should be 20

Time Remapping appears to be working normally in your file here.

I have loaded factory settings and still the same - sphere moves only 10 frames in new build.

Sybren A. Stüvel (sybren) lowered the priority of this task from Waiting for Developer to Reproduce to Confirmed, Medium.

I can confirm the sphere only moves for 10 frames in current master (03f652b2c1fc7de685185190ff95bdd240540388).

@William Reynish (billreynish) In the screenshot above you can see the vertical line in the timeline is only at frame 5, but it already stops the animation.

Time Remapping is a somewhat confusing feature, because it still looks like everything is at the original frame numbers

The frame indicator at the top is the true current frame, and the line is what this frame is mapped to:

I cannot see a bug here, other than the fact that it could be argued that Time Remapping is somewhat confusing to use.

I use it a lot in running project for the purpose of slowing down complex animation with just one slider. I guess I have learned a little about it.
What I am saying is that behaviour of TR has changed recently and it is not working as it should.
Having our sphere blend fileas an example -
sphere is keyframed from F_00 to F_10.
Earlier, if you set TR to 200 you would slow down animation by the factor of 2, so sphere would animate for 20 frames.
Now if you set TR to 200 animation stays the same - 10 frames (its not slowing down).

Ok, in the latest master I can indeed confirm that Time Remapping is broken.

Assigning to you @Sergey Sharybin (sergey). Feel free to re-assign as you wish.

All previous daily builds

Does it mean there is a 2.8-based version which was working some time ago?

Definitly. Anything two / three weeks back.