Page MenuHome

Closing settings or any child window causes crash
Closed, ArchivedPublic

Description

System Information
Operating system: Windows 10
Graphics card: Intel inside

Blender Version
Broken: 2.80

Open user preferences. Close user preferences. Blender crashes. This happens with the render window too.

Details

Type
Bug

Event Timeline

Sybren A. Stüvel (sybren) triaged this task as Needs Information from User priority.

Please follow our submission template and guidelines and make a complete, valid bug report, with required info, precise description of the issue, precise steps to reproduce it, small and simple .blend and/or other files to do so if needed, etc.

A guideline for making a good bug report can be found here: https://wiki.blender.org/wiki/Process/Bug_Reports

Marking as "Incomplete" until the requested information/data is provided.

Sorry, that was over abbreviated.

I'll try that again...

System Information
Operating system: Windows 10
Graphics card: Intel inside

Blender Version
Broken: 2.80 rc3

Closing any child window that blender creates causes a crash.

Open blender with the default cube. Open user preferences, then re-close user preferences. Blender immediately crashes.

This also has happened with the render window.

"Intel Inside" is a slogan by Intel, not a specific graphics card model. Please go to Help → System Info and save the file. You can then attach it here.

Also test with the latest version from our buildbot to see if the problem still exists.

Sorry 'bout that.
Here's the file:

Edit: downloaded 2.80 official release today at 10:22 AM EST and the problem was still there. Is that the latest?

That is the latest.This might be related to your driver version of the cpu can you update the drivers

That's the latest release, yes, but not the latest available version of Blender. You can get that from our buildbot, from the link I posted here yesterday.

Please:

  • Give us your exact Blender, OS and GPU (including drivers) versions, as requested in the template!
  • Ensure both your OS and drivers are fully up-to-date (and use official GPU drivers, not those provided by windows or tablet/laptop maker).
  • Try to disable any running antivirus.
  • Ensure you have no python executable available in your %path% envvar.
  • Try to re-download and re-install Blender.
  • Try the latest build from our buildbot.
  • Try to start Blender in factory settings (--factory-startup commandline option) (this will ensure whether this is a userpref or addon issue or not).
  • Try to tweak your GPU driver settings (e.g. try different values between 'performance' and 'quality' if you have such slider, etc.).
  • Launch Blender from the command line with -d option and attach as text file here any error printed out in the console (do not paste it directly in comment).
  • Try to run Blender through Software OpenGL, this will be much slower however, if everything works then it means that the bug is spefic for your GPU/Driver and you should report the bug to your GPU vendor instead.
    • On Linux/macOS, Official releases come with blender-softwaregl
    • On MS-Windows: Download this dll and copying it so its located in the same directory as 'blender.exe' and run Blender normally.
  • Blender 2.80, downloaded July 31 (IDK how to find more info). Windows 10 Home edition version 10.0.17134 Build 17134, 64 bit. I don't appear to have a GPU, though I'm not sure if that's possible. My processor is an Intel Celeron N3350 @ 1.10GHz. I am running Intel HD Graphics 500, driver version 25.20.200.6373, Microsoft DirectX 12.0, GOP 10.0.1036.
  • Will try and verify.
  • Windows defender is running. Will test.
  • I do. Will test.
  • Okay to the rest. Thx.
Bastien Montagne (mont29) closed this task as Archived.
Bastien Montagne (mont29) claimed this task.

More than a week without reply or activity. Due to the policy of the tracker archiving for until required info/data are provided.

Sorry I never told you. It was an addon. Now fixed. I didn't figure out qwhich one though :P