Page MenuHome

Armature bones parent/child relations lines only shown in Edit Mode
Open, Waiting for Developer to ReproducePublic

Description

System Information
Operating system: Linux-5.2.4-arch1-1-ARCH-x86_64-with-arch 64 Bits
Graphics card: GeForce GTX 1050/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 430.34

Blender Version
Broken: version: 2.80 (sub 75), branch: makepkg, commit date: 2019-07-29 14:47, hash: rBf6cb5f54494e Arch Linux package
Worked: (optional)

Short description of error
In previous versions, the lines were shown in nearly all editing modes in 3d view. Since 2.80rc1 they only shown in Edit Mode

Exact steps for others to reproduce the error
Create Armature object
Select it
Switch to Edit mode
Add some bones, better not connected, set their parent.
Switch back To Object Mode

Details

Type
Bug

Event Timeline

xDShot (xDShot) updated the task description. (Show Details)
Philipp Oeser (lichtwerk) claimed this task.

Object mode only shows relations between objects.
(This was also the case in 2.79)
(also checkedd other 2.8 version from months back and apparently this was always like this)

For bones these show up in editmode as well as pose mode.

Dont see a bug here (unless you are saying these dont show up in posemode for you? Or you can point to a version where this was showing in object mode as well?).
@xDShot (xDShot): will close this, but feel free to comment agina/reopen if issues persist...

Here how it looks in 2.79a

in 2.80

Philipp Oeser (lichtwerk) lowered the priority of this task from Needs Triage by Developer to Waiting for Developer to Reproduce.

Hm, interesting, apparently Stick and Wire display type displayed this in 2.79 in object mode.
No idea why that would be, let me check code here...