Page MenuHome

Blender crash randomly when use gradient on Weight Paint mode
Open, Waiting for Developer to ReproducePublic

Description

System Information
Operating system: Windows-10-10.0.17763 64 Bits
Graphics card: GeForce GTX 1060/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 431.60

Blender Version
Broken: version: 2.80 (sub 75), branch: master, commit date: 2019-07-29 14:47, hash: rBf6cb5f54494e

Short description of error
I will randomly crash when you press alt + left mouse [and alt+ctrl+left click] on weight paint mode

Exact steps for others to reproduce the error

  • just try to do gradient in weight paint mode [with keyboard shortcut], it will crash randomly sometimes.

I speed up video since it happened randomly

Details

Type
Bug

Event Timeline

Germano Cavalcante (mano-wii) triaged this task as Needs Information from User priority.

I can't reproduce the problem using the default cube, subdivided a few times.
Please provide simple steps to reproduce the problem. (Preferably from the default cube).

Hmm. I haven't been able to replicate this after several minutes of trying on the default cube. I'm wondering if there's something about your file or system that's tripping you up...

Have you tried resetting to factory settings (in case you have a glitchy addon) and seeing if this persists?
Does the same thing happen in other files (such as the default cube, or other unrelated meshes in other files)?
Are all your drivers up to date?

My Testing System Information
Operating system: Windows-10-10.0.17134 64 Bits
Graphics card: GeForce MX130/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 391.25
Blender Version
2.80 (sub 74)

No, it not work with default cube

It happened when I import model to blender [.fbx/.dae]
I try factory setting it still won't work, it usually crash when I hold Alt then left click to paint

It not crash on all file but some file will

all driver are up to date

model that crash on 2.8 will not crash on 2.79

Can you maybe create a blend file with one of the imported object models that causes the crashing issue? It would help the developers to investigate the issue further if you uploaded the file.

Hi, I have the same problem with the attached file, just try to apply the gradient on weigth tool and it will crash always (this is my first bug report, sorry if this is not the way to do it)

it is a simple file so i will investigate wich is the step that produce this error, however I did not import any asset in the scene as was mentioned above.

System Information
Operating system: Windows-10-10.0.17763 64 Bits
Graphics card: GeForce RTX 2060/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 417.77

Blender Version
Broken: version: 2.80 (sub 75), branch: master, commit date: 2019-07-29 14:47, hash: rBf6cb5f54494e
Worked: (optional)

I dont know exactly which step could be producing the crash, but I managed to reproduce it consistently in 3 new files so this could help

sorry if the video is too long, i did it exactly as it happened the first time

Bastien Montagne (mont29) raised the priority of this task from Needs Information from User to Waiting for Developer to Reproduce.Tue, Aug 13, 5:54 PM