Page MenuHome

Dopesheet Editor: Moving keyframes by a number value doesn't work
Closed, ResolvedPublic

Description

System Information
Operating system: Linux-5.0.0-21-generic-x86_64-with-debian-buster-sid 64 Bits
Graphics card: GeForce GTX 1080/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 430.34

Blender Version
Broken: version: 2.81 (sub 1), branch: master, commit date: 2019-08-02 08:09, hash: rBb54528fa1ed4

Short description of error
Moving keyframes in the Dopesheet Editor (by hitting G and typing a number value) doesn't do anything.

Exact steps for others to reproduce the error
New file
Select the cube and insert a keyframe
Go to the Dopesheet Editor
Select the keyframe, hit G and type a number (in order to move it that many frames)
...nothing happens...

Event Timeline

matc (matc) triaged this task as Needs Information from User priority.

It's working for me on windows. Can you test if it works when blender is started with --factory-startup?

heini (ogonek) added a subscriber: heini (ogonek).EditedAug 5 2019, 2:43 PM

Can confirm this. I reset to factory defaults. Neither moving nor scaling keyframes with G/S + numerical input works. It does so in the graph editor.
(blender-2.81-9fbf522dd8c0-win64)

matc (matc) raised the priority of this task from Needs Information from User to Needs Triage by Developer.

I was probably testing 2.80, that's why it was working for me.

@Germano Cavalcante (mano-wii) Could you take a look at this? 81dc76c19cff51c9 is the commit that introduced this.

Moving Keyframes works now, but scaling still doesn't. Should I open a new report for that?