Page MenuHome

Fluid simulation viscosity presets do not update immediately after clicking presets.
Open, Needs Triage by DeveloperPublic

Description

System Information
Operating system: Windows 10, 1803.
Graphics card: GTX 1070
CPU: i7 4770k
Blender Version
Broken: 2.80 (sub 75), branch: master, commit date: 2019-07-29 14:47, hash: f6cb5f54494e
Worked: 2.79b (the dropdown went away as soon as I clicked showing that it registered)

Short description of error
This is a small (but annoying) UI error: when switching fluid viscosity presets the values do not update until the user's mouse leaves the preset window, confusing me a bunch thinking my clicks were not registering. Upon my mouse leaving the pop-up window the values do update themselves. An easy (presumably) way to fix could be to just make the window close by itself as soon as I clicked, but this may potentially break the "new preset" functionality.

Exact steps for others to reproduce the error
Based on the default startup or an attached .blend file (as simple as possible).

  1. Open Blender default startup
  2. use default cube, size up & make it a fluid domain
  3. create something mesh (eg. sphere) inside fluid domain cube, and make that fluid.
  4. select fluid domain cube, go to physics>Viscosity see dropdown next to the word "viscosity" (the placement here is confusing as well) and select a preset. You'll see the affected values don't update till mouse leaves the pop-up.

I tested with fresh blender install & daily build (2.81- 8.2.19)

Details

Type
Bug

Event Timeline