Page MenuHome

"Help -> Report a Bug" throws "400 Bad Request" message
Closed, ResolvedPublic

Description

System Information
Operating system: macOS High Sierra
Graphics card:

Blender Version
Broken: 2.80 2019-07-19
Worked: (optional)

tried to submit a bug report using "Help -> Report a Bug" and received an error message "400 Bad Request"

Exact steps for others to reproduce the error - - try submitting a bug request using Help...
Based on the default startup or an attached .blend file (as simple as possible).

Details

Type
Bug

Event Timeline

it's ok until the %0A then it http 400's

Duplicate of T68147, which might be a duplicate of T68007.

Happens for me, too, and I don't think it's Blender. I have reported bugs from 2.80 and 2.80 RC3 before, and both are giving me the 400 error right now. It's on the maniphest/phabricator or whatever this site is called.

The logs show:

2019-08-03 04:45:26: (response.c.346) invalid character in URI -> 400 /maniphest/task/edit/form/1?description=%2A%2ASystem%20Information%2A%2A%0AOperating%20system%3A%20Linux-4.15.0-55-generic-x86_64-with-Ubuntu-18.04-bionic%2064%20Bits%0AGraphics%20card%3A%20GeForce%20GTX%20960/PCIe/SSE2%20NVIDIA%20Corporation%204.5.0%20NVIDIA%20390.116%0A%0A%0A%2A%2ABlender%20Version%2A%2A%0ABroken%3A%20version%3A%202.80%20%28sub%2075%29%2C%20branch%3A%20heads/v2.80%20%28modified%29%2C%20commit%20date%3A%202019-07-29%2014%3A47%2C%20hash%3A%20%60rBf6cb5f54494e%60%0AWorked%3A%20%28optional%29%0A%0A%0A%2A%2AShort%20description%20of%20error%2A%2A%0A%5BPlease%20fill%20out%20a%20short%20description%20of%20the%20error%20here%5D%0A%0A%2A%2AExact%20steps%20for%20others%20to%20reproduce%20the%20error%2A%2A%0A%5BPlease%20describe%20the%20exact%20steps%20needed%20to%20reproduce%20the%20issue%5D%0A%5BBased%20on%20the%20default%20startup%20or%20an%20attached%20.blend%20file%20%28as%20simple%20as%20possible%29%5D%0A%0A

An old Blender 2.77 redirects to https://developer.blender.org/maniphest/task/create/?project=2&type=Bug and shows:

I'm wondering if it's:

http://redmine.lighttpd.net/projects/lighttpd/wiki/Server_http-parseoptsDetails

We run 1.4.54, which we just upgraded to, and that page mentions:

  • "method-get-body" => "enable" (since 1.4.54)
    • permit GET sent with request body (default: reject with 400 Bad Request)

Okay, seems that specifically it was:

  • server.http-parseopts = ( "url-ctrls-reject" => "disable" )

After a reload, the page loads fine now. The question is, why was that done? The original bug report was one guy asking a valid "WHY", and the other guy taking offense, but not really answering the question, so I really don't know about any consequences of this. That said, I don't feel that we can afford to break bug reporting for _every_ Blender release, do you? :)

I'll leave you guys to close the report, but I will mention that the old 2.77 URL is still broken, so perhaps we should keep it open until we figure out what is going on there, as well.

no sorries - CLOSE it

to LazyDodo; for myself, please close this report - thanks

Sergey Sharybin (sergey) closed this task as Resolved.Sep 4 2019, 11:44 AM

Seems to be fixed now.
Thanks everyone, closing! :)