Page MenuHome

Missing blendshape functionality from previous Blender versions.
Closed, InvalidPublic

Description

Blender Version: The official release for 2.80

Short description of error:

The options menu for blendshapes allows us to create a "new shape from mix". The expected behavior is to generate a shape that will look as the mix of the blendshapes active when the function is triggered.

A very convenient part of this was that the vertex masks utilized on the active blendshapes were taken into account when baking into a "new shape from mix". This new generated shape would therefore not present any masked parts from the previously mixed blendshapes. Unfortunately, this no longer is the case, and baking shapes from shapes that have been masked, completely ignores the masks utilized on the active shapes.

This way of masking shapes was a very neat thing we could do and I hope it hasn't been taken out intentionally, as it was a huge timesaver for blendshape artists.

Amazing work on Blender, regardless. Thank you for your work.

Details

Type
Bug

Event Timeline

William Reynish (billreynish) triaged this task as Needs Information from User priority.

I find it a little hard to understand this fully. Can you provide a specific set of steps to reproduce this issue, which reliably shows how this changed from 2.79 to 2.80?

Bastien Montagne (mont29) closed this task as Invalid.
Bastien Montagne (mont29) claimed this task.

More than a week without reply or activity. Due to the policy of the tracker archiving for until required info/data are provided.

Hello!

I'm sorry I opened the account explicitly to open this bug. I am not used to the platform yet: I replied through email but I see now that I read your last email that it was rejected by the server. I don't know what made me think I was supposed to reply by email, my bad.

I tried doing this again and for some reason it worked as expected. I guess I was using my previous beta build and by mistake did not realize that, and that's why the bug was present. "New shape from mix" is working as expected: taking into consideration vertex group masking into the mix.

Sorry for the bother and I wish you guys the best, I've been a Blender user for over 5 years now and I seriously think it's the best 3D Software out there, thank you.