Page MenuHome

Python misconfiguration in Mac build
Closed, ResolvedPublic

Description

macOS Mojave 10.14.6
Radeon RX 580 GPU

Version 2.80 (2.80 2019-07-29)

Blender seems to be working fine, but BlenderGIS add-on not working on this system. Author of add-on suggests the python is misconfigured in Blender build.

Seems like the sqlite python module is not available in your Blender installation which is anormal because it's a standard python module. The issue is related to Blender itself not BlenderGIS. I think there is a missconfig when the Blender team compiling this MacOS binary and it must be reported into Blender bugs tracker.

Screengrab attached.

Details

Type
Bug

Event Timeline

Brecht Van Lommel (brecht) triaged this task as Confirmed, Medium priority.

@Arto Kitula (akitula) assigning to you since I guess you will be doing the Python library upgrade.

Python is now updated to 3.7.4, check if it works now.

Hi. Still the same error I'm afraid. Latest grab attached. I'm a little confused why it appears to be trying to look for a local folder on ‘brecht's’ drive when that would be impossible. Good luck... again. Thanks.

Also wanted to check whether this really was a Blender issue or the BlenderGIS add-on, after all?

Check python console and if the version is 3.7.4, your build is up to date.

Console states 3.7.0. That was from a version of Blender downloaded again today, 22 August. Do I need to try that again or go elsewhere for a 'new' build? Thanks.

Wait for buildbot to be able to build new one, it should have the new one.

Blender 2.8.1 build now has Python 3.7.4 and the BlenderGIS add-on now installs. Thank you.

Philipp Oeser (lichtwerk) closed this task as Resolved.

Glad to hear, closing then...