Page MenuHome

Blender 2.8.75 Revert & Save not working for me
Closed, ArchivedPublic

Description

System Information
Operating system: OS X High Sierra
Graphics card: AMD Radeon R9 280x 3GB

Blender Version
Broken:
2.8.75 Release

Short description of error
Used revert to go back to my last saved state. Upon reverting, things were not saved from last save, and objects had been moved and rotated. The scene uses Mirror Modifier across X axis. I correct the models placement and rotation put everything back, save and saved a copy. Both opened in the same old incorrect state. I saved the file to USB and opened on my Windows 10 (v.1903) and the files had the same incorrect placement and rotation. Corrected placement and save, saved a new copy on Windows machine. Open both files, same thing, nothing was saved. Copied files, pasted to a brand new scene, correct placement, save. Doesn't save the changes.

Exact steps for others to reproduce the error
The only thing I can verify and replicate every time is, save the corrected scene as OBJ or DAE and open those files, same issue, nothing saved. I have attached the scene file and system info. Please note, the system info will reference the latest Alpha, I wanted to see if the issue persisted in the latest build, it does. While on Windows machine, I even tried copying the contents of the scene and pasted to a new doc. Saved it, and when opening, everything was reverted back to the incorrect positions. The attached file is in the state that it always reverts to. Please try moving the collection "Monster" to where the two mirrored cubes are and rotate and save. Then reopen scene. For me, nothing will save. Tried opening and working with the autosaved versions, exact same thing.

Thank you,

-Leif

Details

Type
Bug

Event Timeline

From what I can see, your objects have keyframes on them but Autokey is not enabled so naturally when you move things around but don't set new keys, objects revert to their keyframed state when you change the frame or reload the file. I have tried to move your objects, manually set new keyframes and after saving and reloading everything seems to be where it should, I have also tried to remove all the keyframes and after saving and reloading everything was fine as well.

Sybren A. Stüvel (sybren) triaged this task as Needs Information from User priority.

@Leif Buckley (Punker3D) please confirm @Alex (SpectreFirst) 's suspicion, or provide us with exact steps to reproduce the issue.

Thank you very much, Alex. I can only assume I accidentally hit the "i" key without knowing it and added a base keyframe? I have the animation timeline completely hidden, but when I expand it I see one. My apologies for this time wasting effort. I thought for sure I had corrupted my scene.

I have deleted the keyframe, corrected the scene and saved, it opens perfectly now.

Again, thank you, and my apologies for reporting this as a bug. Not new to 3D, but relatively new to Blender and made an obvious mistake.

-Leif

Brecht Van Lommel (brecht) closed this task as Archived.Wed, Aug 7, 4:10 AM
Brecht Van Lommel (brecht) claimed this task.