Page MenuHome

EEVEE (and Workbench) engine show too much clipping errors in render.
Closed, ArchivedPublic

Description

System Information
Operating system: Linux-5.2.2-1-MANJARO-x86_64-with-arch-Manjaro-Linux 64 Bits
Graphics card: GeForce GTX 550 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 390.116

Blender Version
Broken: version: 2.81 (sub 0), branch: master, commit date: 2019-08-01 10:32, hash: rB5fde4494f654

Short description of error
I have this scene where I have placed a camera somewhat distant from the model(s)... and I get clipping artifacts all over the place. I get these artifacts in EEVEE and Workbench; with Cycles, of course, none of those artifacts are present.

I know EEVEE (and Workbench) have limitations, but those clipping errors I think are way too notorious and easy to appear in renders... I imagine that increasing the precision of those engines might increase rendertimes and/or memory usage, but I repeat, the current clipping limitations I think are way too messy... I don't know if is possible, but maybe a "clipping" parameter/slider so the user can decide to "sacrifice" rendertimes or memory usage for a better clipping precision.

Exact steps for others to reproduce the error
Attached a .blend file (and renders) where the clipping errors are very noticeable.

Details

Type
Bug

Event Timeline

Sybren A. Stüvel (sybren) closed this task as Archived.
Sybren A. Stüvel (sybren) claimed this task.

This is caused by your camera settings. It uses a huge range for the cliping planes, from 10cm to 1km. Setting it to a more moderate 400m to 800m solves this issue.

In 9 years using Blender, I have to admit that I didn't know of that "trick"... I didn't know that the camera clipping limits range would affect the precision of the clipping in those render engines. Thank you so much for the information!