Page MenuHome

Timeline key-frames can be made to disappear during mouse grab in Blender 2.80
Closed, ResolvedPublic

Description

Broken: 2.80 release

In the latest release, the timeline can have the keys scrolled off with the middle mouse button, due to the design of using a dope sheet as a timeline.

See:
https://devtalk.blender.org/t/timeline-key-frames-can-be-made-to-disappear-during-mouse-grab/8790

Event Timeline

William Reynish (billreynish) lowered the priority of this task from 90 to Low.

Indeed the scrolling bounds are off a bit in the Dopesheet/Timeline.

@Campbell Barton (campbellbarton) feel free to re-assign as you wish.

Richard Antalik (ISS) closed this task as Resolved.Feb 5 2020, 7:58 PM
Richard Antalik (ISS) claimed this task.

Now it's same as in 2.79, so I assume issue is resolved.

Hi,

I just had 1 hour of searching this issue, my keyframes were gone from view and they were actually scrolled up.
it was a frustrating experience. it working on new files and after I closed and reopen my file they were still gone, the Blender file saved also the timeline verticle scroll.

please fix it.

Hi,

I just had 1 hour of searching this issue, my keyframes were gone from view and they were actually scrolled up.
it was a frustrating experience. it working on new files and after I closed and reopen my file they were still gone, the Blender file saved also the timeline verticle scroll.

please fix it.

Sorry I am not exactly sure what the problem is in your case. If you think you have found bug in Blender, please make new report and follow all instructions. If you think some behavior should be changed, use site like https://blender.community/c/rightclickselect/

hi Richard,

please see the video the original reporter added at the top. you can see the Keyframes are scrolled up although only one keyframe line exists. it doesn't matter the height of the timeline window open, it will have scroll anyway and the keyframes are "gone" without any scroll to be present.