Page MenuHome

Video editing render / preview disregards the composite and won't display right
Closed, InvalidPublic

Description

System Information
Operating system: Windows-10-10.0.17134 64 Bits
Graphics card: Radeon RX 580 Series ATI Technologies Inc. 4.5.13521 Core Profile Context 24.20.11021.1000
CPU: AMD FX-8350 8 core 4 GHz
RAM: 2x4 GB + 2x8 GB (24 GB)

Blender Version
Broken: version: 2.80 (sub 75), branch: master, commit date: 2019-07-29 14:47, hash: rBf6cb5f54494e
Worked: (optional)

Short description of error
I've been struggling for hours to get video editing to work. The nodes are correct, the viewer (and the backdrop) displays the output perfectly fine. It's also connected to the composite. The problem is, the preview displays wrong, the keying and the alpha over is disregarded, and it won't render right. The rendered pic is still the preview you see on the attached screenshot.
I looked up several possible solutions to no avail. I sent the file to my friend and he had no problem, it should work fine, so it must be something to do with my rig. It might be a hardware related bug, but I'm not sure.

Exact steps for others to reproduce the error
None that I know of, it worked for my friend. That's why I'm writing a bug report instead of just asking on a forum how to do it. I had issues with my GPU previously regarding to Blender 2.79 - none of the textures would render, while they worked for my friend, and in the meanwhile, rendering with CPU worked for me. I suspect I got lucky again...

Thank you!

Details

Type
Bug

Event Timeline

I'm a little confused with what you trying to do. But...
If your trying to make a composite and then edit that composite (in VSE) then it should be in 2 scenes.
Something like this:


But you also say that it doesn't display right, did the premultiplication fix that?

I tried her file and it simply renders as intended on my computer. The green background becomes the snowy image. Her problem is it renders the greenscreen version without the added background image. As you can see on the preview too on the attached image. This node setup should simply work.

It is like the alpha over node does not work on her GPU

Still trying to figure it out. I watched several tutorials, no one bothered with scenes or premul and it all worked fine for them, the minute they connected it to the compositor, it showed up the way it should be after keying.
Unfortunately, premul doesn't fix anything for me.
Now I received another test file. The "alpha over" seems to work - the render is same as the viewport, displaying correct.
If I go work in the sequencer, it completely disregards the compositor (I get the green screen Dany render if I hit F12), regardless of how many scenes I have and I can't find anything helpful around the web to fix it. Maybe I'm wrong, but if the settings were messed up, I don't think it'd work for my friend (Ákos).

So, let's see if I understand correctly...

my computer. The green background becomes the snowy image.

If your talking about the Video Sequence editor's preview showing the composite, it shouldn't, that only shows what is in the VSE timeline.

In the file both the VSE and Compositor are fighting for post processing, though you can override in the output settings:

Why is the Video sequencer being used? Using both in the same scene (in my experience) causes headaches.


after refresh...


@Dot K (imfromthespace) Okay if it was tutorials for 2.7 A LOT has changed...

the minute they connected it to the compositor, it showed up the way it should be after keying.

Okay, in your screenshot, the bottom right preview is showing dany.jpg. If you want to see the render preview you need to switch to the Image Editor (Shift + F10) and choose "render result".
Currently,... and this is what I think is the bug, having both the Compositor and Sequencer active is displaying nothing. Hadn't set the file path correctly
What exactly are you trying to do? Remove the background from one image, one video, edit a keyed video ect..

Okay, in your screenshot, the bottom right preview is showing dany.jpg. If you want to see the render preview you need to switch to the Image Editor (Shift + F10) and choose "render result".

Technically, that's not "dany.jpg", that's the (((composite output???))) sequencer preview, and the exact same as the render result, and as you can see, definitely not the expected result that can be seen in the viewport. My friend hit F12 and it rendered OK on his PC.

What exactly are you trying to do? Remove the background from one image, one video, edit a keyed video ect..

Remove the green screen from a video (but here I used a pic so the file would be small) and have it over another background. I need a lot of layers like this. It worked in Sony, but that struggles with too many video tracks and chroma/luma keys, so I'd prefer to use Blender if I could get it to work.

LOL it keeps getting funnier by the hour, and I have no idea what's happening.
So I switched the green screen jpg with a photoshopped transparent png and that worked:


Then, I disconnected the png and reconnected the green screen jpg with the keying, and it ! WORKED ! WHAT? WHY? HOW? I don't know. It's definitely bugged.

Well, alright. I went ahead and put a movie clip in there. Same thing happening - the keying doesn't go away, it's just as bugged as previously the green screen jpg was.

I don't get it.

Also, the viewer and the sequencer preview are out of sync. Idk if this is normal.

Christopher_Anderssarian closed this task as Invalid.Aug 7 2019, 6:32 PM
Christopher_Anderssarian claimed this task.
Christopher_Anderssarian lowered the priority of this task from Needs Triage by Developer to Needs Information from User.

Okay, I think I know what's happening.
The nodes (in the compositor) are not connected, in any way, to the strips in the timeline.


The nodes you have setup don't influence the timeline and that's why you see the sequencer preview, in the bottom middle, is untouched.
In the screenshot here, I've manually disabled the sequencer for the post process and as you can see, in the bottom right preview, it renders the nodes...
The reason it's working in T68353#747829 is because you have a transparent image over the wintercrop.jpg. I did the same in T68353#747392, but I had Blender do it, rather than use a pre-processes image.
Depending on what you need done, or are capable working with, you can get Blender to do all of it (like I showed) or do the keying in blender then layer them in Vegas...
Blender should be able to leverage the OpenCL of your RX 580 for the compositing workloads. But ultimately it's your choice. Idk what 'a lot of layers' is.

But as far as I can see, there doesn't appear to be a bug there.

Well, I don't think we ever would've figured that one out. That's a pretty silly "feature" that no one warns you about.

♥️ Thank you very much for your help! ♥️