Page MenuHome

Blender (MacOS, v2.80-release and v2.81-git build) crashes with "Segmentation fault: 11" while rendering an animation
Closed, ArchivedPublic

Description

System Information
Operating system: Darwin-18.7.0-x86_64-i386-64bit 64 Bits
Graphics card: AMD Radeon Pro 580X OpenGL Engine ATI Technologies Inc. 4.1 ATI-2.11.20

Blender Version
Broken:

  • version: 2.80 (sub 75), branch: master, commit date: 2019-07-29 14:47, hash: rBf6cb5f54494e
  • version: 2.81 (sub 1), Commit date: 2019-08-06 20:27, Hash f4e27bc2c981

Worked: unknown

Short description of error
Blender crashes regularly with Segmentation fault: 11" while rendering an animation

Exact steps for others to reproduce the error
This is not a neatly defined crash. While rendering a 2100-frame animation, Blender crashes regularly. With the release build, this seems to be every 100 to 200 frames or so. With a local compiled 2.81 version, the crash is more often, sometimes after 10 frames.

The .blend file is on a local SSD, the output (frame per image) is written to an SMB share on a NAS.

Crash files:




If needed, I can provide the .blend file.

Details

Type
Bug

Event Timeline

Update: storing output in a local directory does not change the crash behavior.

Additional crash files:




I'm replicate this issue since I have the same hardware. Do you use EEVEE or Cycles? Will this happen if you render 250 frames of the default scene?

I am using Cycles.

I tried your suggestion with 2.80 RC2 build, the 2.80 official build and a local compiled 2.81.

Rendering a 500-frame animation of the default scene did not reproduce the crash.

A partial test with Eevee (approx 300 frames) also did not reproduce the crash.

Can you share something minimal that reproduces the crash?

I will try that as soon as I can and update here after 'elimination'.

Sybren A. Stüvel (sybren) triaged this task as Needs Information from User priority.Thu, Aug 8, 6:29 PM

It seems to have been a corruption in the .blend file.

I appended the components into an empty file and now Blender (2.81, local build) properly renders all 3000 frames in one go.

Can you please close the task?

Brecht Van Lommel (brecht) claimed this task.