Page MenuHome

Blender 2.8 Ctrl-Z crash + Very slow Undo on big scenes.
Closed, ArchivedPublic

Description

System Information
Operating system: Windows-10-10.0.17763 64 Bits
Graphics card: GeForce GTX 1080/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 431.60

Blender Version
Broken: version: 2.80 (sub 75), branch: master, commit date: 2019-07-29 14:47, hash: rBf6cb5f54494e

Short description of error

  • Blender crash by doing Undo (Ctrl+Z) several times (if you do it fast with big scenes).
  • Undo take too much time to be effective on big scenes (around 7 seconds).

Exact steps for others to reproduce the error

  • I had the crash many times in a large blender production scene. 17 000 000 polys, 139 objects, 30 collections.
  • Move objects / edit objects / sculpt objects + Ctrl-Z several times.

Unfortunately I'm not allowed to share my blender file.

Details

Type
Bug

Event Timeline

Can you test whether you can cause a crash based on this file? And report back with a specific sequence to cause the crash?

It contains a script that creates 128 cubes with a total of 25'000'000 tris. To run it click Run Script in the text editor.

Undo taking a long time in certain cases is a known limitation, and bug reports should be kept to one issue per report. For those reasons I just wanted to recommend you to keep this focused on the crashing problem specifically.

AntoineR (S_Jockey) added a comment.EditedThu, Aug 8, 11:33 PM

Thanks for your file matc !, I will try to reproduce the crash with your scene.
@Demeter Dzadik (Mets) ; I mentioned the slow undo because it could potentially cause of the crash.

Sybren A. Stüvel (sybren) triaged this task as Needs Information from User priority.Fri, Aug 9, 1:02 PM
Bastien Montagne (mont29) closed this task as Archived.
Bastien Montagne (mont29) claimed this task.

More than a week without reply or activity. Due to the policy of the tracker archiving for until required info/data are provided.