Page MenuHome

Slow animation playback depending on location of mouse cursor in the Blender window
Closed, ArchivedPublic

Description

System Information
Operating system: Windows-10-10.0.18362 64 Bits
Graphics card: GeForce GTX 1080/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 430.86

Blender Version
Broken: version: 2.80 (sub 75), branch: master, commit date: 2019-07-29 14:47, hash: rBf6cb5f54494e
Worked: (optional)

Short description of error

I have a large scene with a vehicle which has an armature in it. When I press the space bar to play the animation of the vehicle armature I get different playback speeds depending where my mouse cursor is placed at the time I press the space bar. If the mouse cursor is hovering over the 3D Viewport I get 25fps but if I hover my mouse cursor over the Timeline and press the space bar I get 19fps. No other changes - just where my mouse happens to be when pressing the space bar.

Exact steps for others to reproduce the error
[Please describe the exact steps needed to reproduce the issue]
You need a heavy scene with an armature in it such that the computer just manages to achieve the desired fps. Then when you move the mouse cursor to hover over the timeline or graph editor or the dope sheet and press the space bar to start playback, the fps will be less than if you press the space bar when hovering over the 3D viewport area of the screen. If you have the mouse cursor over the Outliner or the Properties editor when you press the space bar you also get the higher 25fps playback.

[Based on the default startup or an attached .blend file (as simple as possible)]

Details

Type
Bug

Event Timeline

@Iain McGregor (ijay99) I think, in this way (just by telling) devs can't reproduce the bug. Is you can provide some sample file, and with exact steps to produce the bug?

Hi Abid

I've tried to reproduce it in other files but I can't so I'll assume it is specific to the rig I'm using in my project so the task can be closed.

Is this along the lines of what your issue is?

From: T60336#596645

Similar to that Christopher. In my case when I started the playback of the animation with the mouse cursor in the 3D view it was faster than with the mouse cursor in the timeline and other windows as in my original post. Not sure if it changed as I moved my mouse cursor. It was when I started the playback. Perhaps it is a the same issue but since you are running at higher fps you are picking up the issue as you move the cursor.

Brecht Van Lommel (brecht) closed this task as Archived.
Brecht Van Lommel (brecht) claimed this task.

Which editors are refreshed depends on where you start the playback. This is by design, and starting playback over the 3D viewport will generally be fastest.

Optimizations to animation playback of other editors are possible, but not considered a bug.