Page MenuHome

Unexpected behaviour of object mode mirror, doesn't mirror rotation.
Closed, ArchivedPublic

Description

System Information
Operating system: Darwin-18.5.0-x86_64-i386-64bit 64 Bits
Graphics card: AMD Radeon Pro 580 OpenGL Engine ATI Technologies Inc. 4.1 ATI-2.8.38

Blender Version
Broken: Was broken in 2.79b. now running version: 2.81 (sub 1), branch: master (modified), commit date: 2019-08-06 20:27, hash: rBf4e27bc2c981
Worked: (optional)

Short description of error
The object rotation doesn't get mirrored when using object mode mirror.
Image shows object mirrored in object mode.
Green objects illustrates expectation, Red current behaviour.

The current behaviour would be OK if the Only Origins was checked.

Exact steps for others to reproduce the error
Based on


Mirror the object "Cube" over to negative X in object mode

Details

Type
Bug

Event Timeline

Bastien Montagne (mont29) triaged this task as Needs Information from User priority.

Cannot confirm here from quick test...

Please follow our submission template and guidelines, also read these tips about bug reports, and make a complete, valid bug report, with required info, precise description of the issue (only ONE issue per report!), precise steps to reproduce it, small and simple .blend and/or other files to do so if needed, etc.

I have update the task with a minimal setup.

Bastien Montagne (mont29) closed this task as Archived.Tue, Aug 13, 3:47 PM
Bastien Montagne (mont29) claimed this task.

Ah thanks for the file, I see what you mean now. Think is, that kind of transform is not possible in Object mode (besides along the object's local axes), you'll have to do it in Edit mode if you want a proper mirroring along an arbitrary axis. Thats not a bug, just a usual limitation of Object mode> Thanks for the report anyway.