Page MenuHome

blender crash memory max
Closed, ArchivedPublic

Description

System Information
Operating system:win 10
Graphics card: 2070 super
32g ram
ryzen7 3700x

Blender Version
2.80.75

Short description of error
when i use texture mask to paint blender will freeze and ram usage will go up to max. it causes my pc to reboot once. after that during my testing, pc didnt reboot, just freeze

Exact steps for others to reproduce the error
i have the file for u. its all set up to the point i crash, i packed all file(with my brush all set up). all u need to do is to click the left mouse button on to the cube and blender will crash. i also have a video. i have this log file as well it says "Invalid in-ram queue size (20971520), adjusted to max ram queue size" might be useful.

Details

Type
Bug

Event Timeline

I can confirm that drawing in texture paint mode does allocate quite a bit of memory. The texture that is painted on is present in the material as texture node, but disconnected. If this texture node gets deleted from the material it works fine. It does lag a bit, but that is due to the large image size of both the texture and the brush.

The log file you attached has nothing to do with Blender. It seems that this is from Aria which is part of the OneDrive app.

@Sebastian Parborg (zeddb) @Campbell Barton (campbellbarton) This may be something for you.

hi, thanks for the reply, so u are saying that u didn't crash when painting. so how much memory were u using with my file. with file that small. using all 32gb of my memory is obviously a bug. the log file i acquired from the blender path file, along with other log files and .blend autosave. can this be the reason why i am crashing and using all my memory? one drive somehow messed thing up?

Blender definitely allocates a lot of memory in this case, I stopped it before swapping. The directory where Blender stores temporary files C:\Users\cyber\AppData\Local\Temp\ is used by other applications as well. The error message in that log file does indeed look like OneDrive/Aria it's trying to allocate too much memory as well, so it could make the situation worse.

Bastien Montagne (mont29) closed this task as Archived.
Bastien Montagne (mont29) claimed this task.

We cannot do much here, if you run out of RAM you run out of RAM, and Blender will almost certainly crash. Improving efficiency is always a goal, but that's not a bug. Thanks for the report anyway.

I'm not familiar with how memory is allocated in texture paint mode, but something seems to be going wrong. If I run the Blender file as is, it will run out of memory. However if I delete the unconnected node that reference the texture that is painted on, it will peak at about 4 GB.

Texture node in the shader that is disconnected but heavily impacts memory allocation.

Aborted run that allocates until out of memory

Project without the texture node

I also noticed that the texture isn't displayed in the image editor, but when the texture node is removed it displays correctly. Furthermore the perspective in the texture paint mode changes when the texture node is removed, which is very strange.

Texture paint workspace when loading the file

Texture paint workspace after removing the texture node in the shading workspace

This was tested with 52421e9ace74

@Robert Guetzkow (rjg) cannot confirm that here, for me deleting the unlinked texture node does not prevent Blender from eating all available RAM for me...