Page MenuHome

Need Blender 2.81 Require Opengl 3.1
Closed, InvalidPublic

Description

All Computer don't have a powerful processor or a graphics card .Some of do not have money to buy graphics card. But Intel HD Graphics is on all the computers. And all the Intel HD graphics have opengl 3.1 .They can't use blender 2.80 because of the opengl error require opengl 3.3 .So we want blender a opengl version require of opengl 3.1 .

Details

Type
To Do

Event Timeline

Watson biard (biard) created this object with edit policy "Administrators".
Watson biard (biard) triaged this task as Waiting for Developer to Reproduce priority.
William Reynish (billreynish) closed this task as Invalid.

Please fill out the bug report form correctly.

Integrated Intel graphics do in fact support OpenGL 3.3, provided they are within a certain age. Also make sure to update drivers.

AFAIK newer Intel graphics after core 6th gen CPUs are capable of OpenGL 4.x. Yes on my machine who has a 4th gen core i7 mobile processor, blender will nor run unless it uses nvidia video card.

The core graphics is very limited in functionality, although recent processors has improved a lot, the functionality is still limited and speed is a problem too. On a 7th gen core i7, eevee will run but seems broken here and there.

The ui *should* run fine with gl version 3.1. Maybe a good idea to do the check only for eevee. But keep in mind that viewport does require some advanced apis to be able to run.

Bastien Montagne (mont29) raised the priority of this task from Waiting for Developer to Reproduce to Needs Triage by Developer.

Also next time, please DO NOT:

  • Add projects (none of them) as suscribers, that will add tons of noise for many people.
  • Triage the task yourself, that is for tracker managers to do, not users.
  • Create TODOs or design tasks, those are reserved to active developers
  • Add completely unrelated tags.

So we want blender a opengl version require of opengl 3.1

Unfortunately this is not possible. Computers without OpenGL 3.3 will have to stick to Blender 2.79.

We could make it more prominent in the site, as long with our guideline for that. That said this doesn't qualify as a bug report, and I will have to close it now.
Thanks for reaching out. Bear in mind though, for future reports, that this page is not for feature requests.

i mean i have laptop with i5 3210M that CPU is like 6-7 years old... and blender works on it ( INTEL HD4000)...

so for real.. i was expecting bigger blender minimum requiments.

Most important u can BUY GPU Open GL - blender supported.. for less than 50$ brand new.