Page MenuHome

Bent concave 2D curve triangulation problem w/ modifiers applied
Open, Confirmed, MediumPublic

Description

Broken: 2.80

(I think the problem is triangulation)
Triangulation sometimes has problems with concave shapes, and I believe this is caused by triangulation (without overlaps) being much more difficult in 3d than 2d. But the problem shouldn't really exist (at least in my case) because the triangulation would work fine using 2D triangulation by projecting the points to 2d along the average normal of the face (it bends less than 90 degrees, so 2D triangulation would be perfect).

Open the project, the shape is completely wrong on the flat faces when using the curve modifier. It's supposed to be a concave crescent shape, instead of the convex hull sorta shape it has now.

Details

Type
Bug

Event Timeline

Campbell Barton (campbellbarton) closed this task as Archived.

This is a limitation with the current modifier stack.

While there is an option to "Fill deformed", he curve is being rotated before being filled, which causes filling to fail - since filling is done in 2D.

Closing.

Philipp Oeser (lichtwerk) triaged this task as Confirmed, Medium priority.

Can confirm triangulation is not great here, maybe @Campbell Barton (campbellbarton) has an idea?

Hm, thing is, even if the deforming curve is 2d only as well, then triangulation fails as well... see [Fill deformed is ON here]


@Campbell Barton (campbellbarton): shouldnt this work then, there is no rotation going on then, right?

@Philipp Oeser (lichtwerk) you're right, this case should work.

Campbell Barton (campbellbarton) renamed this task from Bent concave polygon triangulation problem to Bent concave 2D curve triangulation problem w/ modifiers applied.Wed, Aug 14, 1:52 PM