Page MenuHome

Angle based unfolding in 2.8 produces unexpected results
Closed, ArchivedPublic

Description

System Information
Operating system: Windwos 10 Home, 64 Bit
Graphics card: GeForce RTX 2070

Blender Version
Broken:
2.80

Short description of error
Angle based unfolding in 2.8 produces unexpected and unusuable results.


Exact steps for others to reproduce the error
Check the UV map visible in Blender in the object 'broken'. This is using the default UV unfolding method of Angle Based. Notice how asymmetrical the result is.

Check the UV map of the 'working' object. Here the UV map is nice and symmetrical. The only difference between these is the seam placement of the mouth seam. It's one edgeloop moved.

I'm expecting the result to be like the 'working' one every time, regardless of where I select he loops. The same seam placement in Maya with default settings provides a flawless result. (see below)

Details

Type
Bug

Event Timeline

the weird thing about this one its that the result may change and done properly depending on the scale and position of the object, i saw that since 2.5 but i was never able to get a file to consistently reproduce the behavior in order to report it
position 1:

Position 2:

Sometimes playing with the position of the object (not vertices mesh) you get different results or even the desire one, since this is really annoying to do I use to do a planar uv of the most central part of the model and pin it not nice but works.
I hope some dev take this report and fix this issue because it is there.

I'm not sure if this is really a bug. Does the manual or some other page say that the uv map will be symmetrical?
To me this sounds more like a feature request for an improved algorithm.

@Jacques Lucke (JacquesLucke) The point is, users expect symmetrical unwrapping of meshes that were modeled symmetrical... Especially faces or bodies. Of course if the seams are set symmetrical. But Hennig created all right, Blender didn't unwrapped the area in the way we expect it.

I've visited the Autodesk website for what they are doing in these situations today. There are various possibilities. Particularly interesting is their new "Symmetrised Command" tool. So I suppose this problem was solved there only recently, but not sure.

Whatever. A solution would be essentially important and Hennings example mesh is very good for tests.

Here is the Autodesk manual about symmetrized UVs: https://knowledge.autodesk.com/support/maya/learn-explore/caas/CloudHelp/cloudhelp/2018/ENU/Maya-Modeling/files/GUID-EEAEA43D-D652-48CB-8547-402E9B34156E-htm.html

By the way: Symmtrical unwrapping was important and already possible in Softimage XSI in 2010. I say this, because I'm a XSI veteran and love this piece of software.
https://youtu.be/a8yJSk4kEnw

A bit off topic, but for the Blender devs:
If you are looking for concepts or ideas to solve complex challenges, just take a look into the "old" softimage XSI manual.
http://download.autodesk.com/global/docs/softimage2014/en_us/userguide/index.html

There you 'll find ideas and solution for complex topics like

I don't want to bother you, but it's always good to know what was already possible in the history (Before Autodesk cancelled it for strategical reasons...).
I know there are great modern solutions like houdini, today etc., but XSI offered some solutions that are even not possible taday, but very logic and artist friendly. And all this already in the years 2010-2014 ...

Brecht Van Lommel (brecht) closed this task as Archived.
Brecht Van Lommel (brecht) claimed this task.

All of this is outside the scope of the bug tracker, please use other channels for user feedback and requests:
https://wiki.blender.org/wiki/Communication/Contact#User_Feedback_and_Requests