Page MenuHome

EXCEPTION_ACCESS_VIOLATION when entering Edit Mode
Open, Confirmed, MediumPublic

Description

System Information
Operating system: Windows 10 1903 (18362.239)
Graphics card: Intel HD Graphics 4000

Blender Version
Broken:
Blender 2.80 (sub 75) / 2019-07-29 09:44 AM Windows / Stable
Blender 2.81 (sub 1), branch: master, commit date: 2019-08-13 11:31, hash: 6f9cbbc8ec4f
Worked:
Blender 2.79 (copied mesh over through copybuffer.blend)

Short description of error

When entering edit mode of a specific object Blender crashes with EXCEPTION_ACCESS_VIOLATION. Logs and example .blend provided.

The issue shouldn't be in my GPU, since the same issue persists even with Software Rendering.

Exact steps for others to reproduce the error

  1. Open up example file

  1. Select window_panes and enter Edit Mode
  2. Get EXCEPTION_ACCESS_VIOLATION

Logs (2.80 blender_factory_startup)


Logs (2.81 blender_factory_startup)

Details

Type
Bug

Event Timeline

Bastien Montagne (mont29) closed this task as Invalid.
Bastien Montagne (mont29) claimed this task.

You are using a 4 years old GPU driver. Please go to intel site and update it.

You are using a 4 years old GPU driver. Please go to intel site and update it.

I have a few counterpoints to that. Please read them throughly.

Firstly, as I described in the short description of the error:

The issue shouldn't be in my GPU, since the same issue persists even with Software Rendering.

This was done using the opengl32.dll provided by you guys from here.

For safety sakes, I've appended the logs from the Blender while in Software Rendering mode.

While it is true that didn't have the latest Intel drivers (my mistake), the issue is still present in the latest Intel drivers. Again, logs are below.

And just to make sure that the crash isn't related to my GPU driver or Windows setup I tested it in a Linux environment.

Please consider reopening this issue.

i can confirm, i have a crash with test .blend file on linux Blender 2.80-Stable AMD FX8350, 16GB DDR3, GTX690 2+2 GB VRam- Nvidia drivers 430.40

Bastien Montagne (mont29) triaged this task as Confirmed, Medium priority.

Indeed you are right, sorry... Will investigate further.

@Campbell Barton (campbellbarton) I believe that one would be for you?

Crash happens in CustomData_to_bmesh_block() while trying to copy a CD_FACEMAP layer which source's CustomDataLayer has a NULL data pointer... I'd say NULL pointer here should never happen? Code is not expecting such thing in any case.

I confirm this is happening. Crashes with just clicking at edit mode

Broken: version: 2.80 (sub 75), branch: master, commit date: 2019-07-29 14:47, hash: rBf6cb5f54494e
Operating system: Windows-10-10.0.18362 64 Bits
Graphics card: Radeon RX 580 Series ATI Technologies Inc. 4.5.13570 Core Profile Context 19.8.1 26.20.13001.29010